DD2 wheel base issues

Hi,

I have a major issue with my DD2 wheel base and think I’m getting to the point where I may just sell up and move to a different eco system.

The problem is that the wheel base doesn’t track the wheel position correctly and reacts violently. The issue started last year and I ended up dismantling my rig and moving all the power cables so to try and reduce any EMI. This seemed to fix it so I ended my support ticket. Now it’s back and I can’t fix it no matter what I do. I tried a different power cable and it seemed better but now it’s doing it again.

I have checked the wheel base setting and it’s set to the iracing recommended settings so its not an incorrect setting causing the issue.

If I go into the driver and move the wheel the position jumps around and doesn’t change smoothly like it normally does.

has anyone else had issues like this?

thanks

Gavin

Comments

  • I'd open a new ticket. The wheelbase will need to go back and should come back fixed. Then you'll have a working wheelbase that you can sell to mitigate the cost of your move to a new DD. You wouldn't be wise to sell up when the wheelbase has an issue.

  • I have opened a ticket. I wouldn’t sell on the item without it being repaired. However I think it’s more a design flaw because it had been working fine and if plugged into another computer it seems fine. Last year I rebuilt the rig from scratch whilst waiting for support to respond, it was fine after that. So I put it down to interference or something like that. Nothing changed but the problems back I guess I will waste my weekend trying to fix it again.

  • edited April 5

    If something works properly when plugging it in to another computer I would suspect the computer where it doesn’t work.

    is the pc where you are experiencing problems on grounded by the wall outlet? Same for the power supply of the DD2 which should be connected to a grounded wall outlet.

    Something else you could try is using it with minimal hardware connected, so screen, DD2 and pedals for example.

    Friend of mine had strange issues with a Simecube SC2 pro, we tried everything and at the end we took the SC2 and mounted it on my rig, zero issues. Took everything back to his place and the issue was back within a few minutes so we disassembled the pc and rebuild it from scratch. While removing everything we came to the conclusion that has USB ports at the back had a lot of tension on them, and when putting everything back we made sure the motherboard was aligned properly, clean windows install and the issues hasn’t been back after that day... now I won’t say that this could be your issue also but a crappy hardware component inside a pc can cause weird issues (I had some with bad RAM memory in the past).

    Above was a lucky shot but at the and it worked out. Maybe it’s worth a try while waiting for a response on the support ticket.

Sign In or Register to comment.