DD1 not showing in Properties Page nor in Fanalab

I am trying to install drivers but it just wont work. I tried reinstalling things million times. The base shows in Devices and Printers, so it is clearly connected, but there is nothing in Fanalab or in Fanatec Wheel Properties page? What is going on??? 3000eur for a hardware and I am stuck on installing drivers?? It feels like a bad joke...


  • What driver did you install?

  • started with the one suggested: 2021-01-20-Fanatec_driver_400-1

    then I tried a newer one: 2021.02.01-Fanatec_driver_402

    and also tried one older one: 2020.11.19-Fanatec_driver_381_RC

    the same result with all of those. I was restarting my pc with every install or uninstall.

    In one of my first attempts it was (half) working, and I updated the firmware on the base and the wheel. After that I get this error.

    I also sometimes need to unplug the usb because the pc gets stuck on restarting or reinstalling the drivers.

  • You should try the windows remove software function to uninstall all Fanatec drivers and Fanalab then restart and try to install the driver again. Don't install Fanalab until you have the driver successfully installed.

  • I tried that many times


    The wheel worked only partially, because I was using a USB extension cord!

Sign In or Register to comment.