startup problem with Podium DD1 Racing Wheel F1

I have Podium DD1 Racing Wheel F1 with 346 firmware for Windows 64 bit.

On my computer, on the fanatec software it gives me these items:

wheel base firmware 662,

wheel base motor firmware 30,

steering wheel firmware 28.

both on pc where i installed windows 10 and on ps4, i have problems when i turn on the dd1. sometimes I get the word LOW TORQ on the display but without the possibility of moving forward, as the buttons on the steering wheel do not work.

other times I get out of the word ATTENTION Enable Torque on the display, but even here it is on the steering wheel the buttons do not work and everything is blocked, so much so that I am forced to turn everything off and restart. Could you please help me to solve the problem? I also tried to change the USB port but the problem continues.



  • fanatec sent me an email:

    thanks for your inquiry.

     This issue is most likely caused by a bad connection between steering wheel and the wheelbase. Please take off the wheel and check if the connection pins are bent or broken.

     You can try to install the latest beta firmwares with driver v356.


     Let me know if you find anything and if the issue persists after the update.

     Best regards / Freundliche Grüße

    Phillip Moering

    I replied to the email saying that the connection pins are perfect and intact.

    I can also try to download and install v356 drivers, to understand if the problem is solved. In your forum, however, I read that it is a beta version, and as such it is not stable and definitive as the v346 drivers that I have installed should be, so I would not like to solve this problem and have others.

    I honestly don't know what to do

Sign In or Register to comment.