CSL losing connection to rims as slight pressure is applied

Anyone have any tips on fixing a CSL that keeps losing connection to the rim? As I push and pull on them VERY slightly, my Formula v2 and P1 rims lose connection intermittently to the base. It’s as if the pin receptors in the CSL’s shaft aren’t bent enough to maintain a solid connection to the rims’ pins. As I drive, the rims’ shifters will intermittently stop working as the rim connects and disconnects.

No, none of the rim pins are bent. Yes, I’ve tried tightening the bolts within the QR’s of the rims. Yes I’ve tried rotating the actual pin housing of the rims less than 1 degree while all the bolts were loosened (this helped briefly but did not solve it). Yes, I’ve tried tightening the locking screw on the P1. Yes, I’ve tried putting in the locking screw in the v2 even though it’s the metal QR.

Any other suggestions?

Comments

  • Hi Nate,

    Please create a support ticket via the My Products section of your Fanatec account describing all the troubleshooting steps you've already tried, and our support team will be able to assist with this.


    [Fanatec Community Manager]

Sign In or Register to comment.