DD1 appears to have died

After several months of trouble-free use, something really bad appears to have happened with my DD1. In the middle of a session, all of a sudden the response to inputs, particularly the throttle, became very sluggish, and the "car" was suddenly way down on power. So I stopped the session, exited rFactor2, and opened the Fanatec Wheel Property page, only to find that the DD1 is no longer listed. I powered off the DD1, and powered it back on, but it's stuck in "Low Trq" mode, and it still isn't showing up on the Wheel Property page. In other words, it appears to have bricked. Is there a way to recover from this? If so, please walk me through the steps. Thanks.

Comments

  • I unplugged the power cable for 20 seconds, and plugged it back in, then powered the DD1 back on, and randomly pressed one of the buttons in the button cluster (the one that I have set to turn on the pit speed limiter in rFactor2), and the wheel's display now shows "Hi Trq." However, the DD1 still isn't showing up in the Fanatec Wheel Property page. I haven't tried updating the firmware, because it seems unlikely that a firmware issue could cause the wheel to suddenly stop working, but if you think that's what I should try next, I'll do it. Please advise, as obviously I'm completely dead in the water, with a race coming up soon...

  • What wheel are you using?

    Wheel still in PC Mode when checking on the left top of the DD1 screen?

  • I'm using a Podium Wheel Rim R300.

    Yes, the wheel is still in PC mode

  • edited April 24

    I also disconnected and reconnected the cable connecting the DD1 to the PC, but that didn't do anything, either. And I've also rebooted my PC several times, also with no effect. I suspect there isn't anything wrong with the DD1 per se, but for some reason it has suddenly lost communication with my PC. So I doubt contacting Fanatec support will accomplish anything, because the problem probably isn't with the DD1 itself.

  • Already tried to repair the driver? and then reboot the PC

    Or Uninstall the driver, reboot, install the driver again, reboot and then try again?

    Have had also some problems in the past that the base was not seen by Windows, the re-install solved my problem.

  • Thanks; how exactly do you repair a driver? Sorry, I'm not very knowledgeable about computer firmware and software (I don't know a driver from a putter...)

  • Open the Apps & Features of Windows (Or programs & features) and search for the installed Fanatec driver. When you found that one and you click on the program you should have an option to repair and uninstall. Then just follow the steps.

  • I didn't see an option to repair my driver, so I went ahead and uninstalled it. I haven't kept up with the latest drivers; what's considered the latest safe driver that I should now download? Thanks.

  • I would start with just installing the same driver and try to get that working again. It has worked so should still work after reinstalling.

    If not you can always try a new driver but that involves also upgrading firmwares of everything and can introduce new problems when already not working with your current driver.

  • That took care of it - thanks. Glad it didn't turn out to be something more serious.

Sign In or Register to comment.