DD2 and Formula V2 Wheel issue

Hi guys,

I recently tried to update the firmware for my F1 2018 Steering wheel to version v40, and apparently the update crashed.

I already sent it back to Fanatec so they can check it out. In the mean time, I bought a new Formula V2 and now the same thing happened...

Have you guys had this problem before? Perhaps it might be the DD2 which is the issue when updating the firmware for the wheel?

See picture attached, the update get stuck.

When I turn on the base, it blinks the base LED screen and goes completely black. I also feel a little vibration on the wheel...

I am using the latest driver and base/motor firmware the latest version.

**Everything works fine with the BMW GT2 wheel. Only when I put the Formula V2 I have the problem. Also tried downgrading drivers and firmwares, using different USB ports, using a different computer, but when the wheel is connected to the base, the same thing happens...



  • So, had to get an RMA.

    2 days waiting for them to provide a shipping label and nothing so far.

    They reply 1 email a day. I've been in contact for a week now.

  • 4 days to receive the label.

    DD2 and Brand-new Formula V2 on the way back to Fanatec.

    My F12018 Wheel has been there for the past 4 days and still no updates on what happened to it.

  • F12018 Wheel has been with Fanatec since may 03rd and still no updates on it.

    DD2 and F V2 wheel arrived today at their location. It will now probably take a month for they to figure it out.

    Fanatec support just sucks really bad. Seems like they are completely lost, taking forever to reply to emails, etc...

    So glad I bought a Simucube 2 and Cube controls. Don't have to deal with this Fanatec BS anymore.

Sign In or Register to comment.