Fanatec CSL Hub or CSW V2.5 ffb cutting out momentarily

I have a Fanatec Clubsport V2.5 with the fanatec CSL universal Hub which I have had a great experience with for about 6 months now. However, despite being used lightly in that time period until a week or so ago, an annoying issue has developed

I only play assetto corsa so I dont know if this happens in other games. When drifting as I usually do, I will be sliding along when I feel a small jolt through the wheel and all ffb disappears and the wheel goes as light as if it is turned off. However all the lights on the wheel are still on. After a second or two, the ffb will gradually but quickly return and everything will be back to normal until the same issue occurs again. It does not happen for a while after I start using it, then after the fist time, it happens a lot more often, but there is no pattern to it, it could happen again 10 seconds later, or even too minutes later. Either way, it happens way too often to play for extended period of time as in basically every run I do, I end up crashing because the wheel will not self steer.

Occasionally, when this happens, all of a sudden the game starts going mad, headlights flashing, car constantly refreshing, horn blaring, it is like someone is spamming all the buttons on the CSL hub. When I go into the fanatec wheel property page, it shows that I am using the PS4 edition of the CSL elite P1 wheel. The picture of the wheels show that random buttons are being spammed even though they are not being touched. To fix this i need to turn it off and on again.

At first I thought it was heat as it usually happens when the fans are on at full blast. However the wheelbase does not get hot. I have tried resetting it, reflashing all the drivers and firmware aswell as changing usb location. Even checking tightness of the bolts around the connecting pins where the hub mounts to the wheel. The pins themselves all appear to be in good condition. There is a chance that it is an issue with the hub and not the wheel, or it could be both, I have no idea.

I have sent this issue to support with a video, im waiting for a reply. I have further videos that showcase all opf these issues. I wanted to post this incase anyone has any advice. Does warranty allow me to open it up to have a look? Or should I just leave it be?



  • From what i can tell it seems more or less to be a hub issue.

  • have you find any solution ?. i have the same issue on my csl elite wheelbase.

  • Did you ever find a solution? My CSL Elite just started doing this.

  • Same here, noticed that it mostly happens when i am ahead on a race 🙂.

    Any feedback welcomed.

  • edited January 2023

    Update and fix for me at least:


    Changed usb port, nothing

    Checked all cables, nothing

    Changed wheel, nothing


    Erased all drivers, redownload and reinstall.

    After resetting up everything works fine and much better than before. Wheel seems more responsive.

  • Second update, the problem came back and i noticed it happens when ffb peaks. it restores after one second but this is enough to send you spinning mid corner.

    it seems to me that this is something that is caused from csp. it messes with the ffb along with the graphics. tried to turn it off and had not the issue so far.

Sign In or Register to comment.