CSW 2.5 - PC does not detect wheelbase

My Setup,

• Fanatec clubsport v2.5 base

• CSL Elite P1 wheel

• Thrustmaster T3PA Pro Pedals

• Thrustmaster TH8A shifter

The issue seems to be with the connection between the new fanatec wheelbase and the computer. There is no indication that the wheelbase is connected to the pc. Once the wheelbase is plugged into the power I am able to turn it on and the start button glows red. The wheel base calibrates perfectly. When the wheel is attached I am able to cycle between Xbox one mode (green) and pc mode (red). I am also able to enter into bootloader mode (flashing blue). When the wheel is connected there is a centering spring activated.

As stated earlier the issue is no detection of the wheelbase of any sorts. It does not show up in the game controller window, or any of the software updating applications provided by fanatec's latest drivers/software (version 402). When the usb from the wheelbase is plugged in it does not even show up in the windows 10 device manager window.

Things I have tired:

• Using different usb cords from the base to ensure it was not the cable.

• Downloading "Fanatec_64_driver_292.msi" driver while the wheelbase is connected and powered on. (tried off at first)

• Downloading "Fanatec Driver 402"

• Using different usb ports on laptop

• Restarting computer after uninstall and install of fanatec drivers/software

I have an ASUS vivobook pro laptop that runs racing games no problem as my previous wheel was a thrustmaster tx and everything worked perfectly with that base. I normally use a usb hub but I have been plugging directly into the computer for simplicity and troubleshooting purposes.

Please let me know if you need any additional information to help me get my wheel base going.

Thank you


  • Connecting a wheel through a HUB is a no-no, so I would not go back to that situation.

    I would start with uninstalling all wheel-related drivers (also the Thrustmaster driver if any), restart PC and connect the wheel base directly to a USB port on the PC. When the wheel base has started up and it's set to PC mode, Windows should detect it and probably install some generic driver. If not, then try connecting it to another PC to see if it is detected there.

  • Hello Remco,

    My buddy actually made this post for me. Thank you for replying. I uninstalled all my drivers including my thrustmaster drivers, which I did have. Unfortunately this did not change anything. The wheelbase is still undetected by the computer completely. I also plugged the wheelbase into a different computer as you suggested and downloaded the newest fanatec driver and the wheel was not detected at all on that one either.

    Something to note. My friend came over with his fanatec v2.5 and plugged it into my setup and with no changes made and it detected it and we were up and racing within a minute.

    This leads me to believe that it is either some kind of firmware block that is not letting the wheel be detected or simply a hardware issue.

    I also tried plugging it into my brothers xbox one and putting it into xbox one mode. The xbox was not able to detect it either.

    Please let me know what you think and if you have any other suggestions.

    Thank you for your time!

  • Sounds like a hardware problem with the wheel base, so you would need to contact Fanatec support. Most likely the USB connector is faulty, since you stated that the wheel auto-calibrates properly (assuming that it shows the base and wheel firmware versions on the wheel display at the end).

  • Unfortunately I agree it is most likely a hardware issue. When the wheel finishes calibrating it shows 684 then 022. I didn’t know what these meant, are they the base and wheel firmware versions?

  • So I took the wheel base apart a few days ago and found that the media port for the usb cord was starting to separate. I pushed it back into place but unfortunately when it was pushed up it cracked a small component on the motherboard. I am not sure if it can be repaired or if I will need a new motherboard. Do you know where I could get a new mother board?

    I have attached a picture wit the cracked piece circled in red.

  • So it was a hardware issue all along.

  • Please contact Fanatec Support and link this thread in your request. Fanatec is the only place you can get a new wheel base main PCB from.

    BTW the numbers that show on the display after the autocal are the wheel base and motor firmware versions.

Sign In or Register to comment.