ITM does not work on ANY game

Hello everyone, first excuse my english if I do some mistakes.

Second: I own a Fanatec ClubSport Base V2.5 with a Podium Hub, Button Module Endurance in combination with a R300 rim. I'm owning this setup now for a couple of months and the ITM worked I updated all drivers (Base, Podium Hub, BME and so on..).

I have the latest FanaLab Software 1.54.4 installed plus all latest drivers (see picture). I can enter the ITM display by pressing the "tuning button" and rotating the "funky switch", I can see all 5 pages of it but ITM doesn't show me ANY information at all. Not on Assetto Corsa, Assetto Corsa Competizione, rFactor 2, Automobilista 2, RaceRoom Racing Experience or ANY other game. And even stranger is "enable telemetry" is greyed out on every game accept iRacing (and no, I couldn't check if it works there cause I have no iR subscription).

I deleted every single Fanatec driver, FanaLabs driver, profiles and any other Fanatec related file, reinstalled it for more then 10 times now, tried to repair the installation.

Every single button of the BME is working, tuning menu from FanaLabs and the Base is free of any issues, dynamic FFB is working aswell.. only problem: I can't get any information of the ITM itself.

I'm absoluteley clueless and need help cause Fanatec's support didn't answer..


Sign In or Register to comment.