Podium DD2 How to set up for drifting

So I've seen streams online where people are using this wheel base to drift and I see that the counter steer spins really fast automatically. But when I go to test this, it doesn't really spin back by itself, I have to manually do it as if I don't have any power steering or something

So my question is how to set the settings so it can do fast counter steers automatically by itself? I tried already the spring effect to 150% I believe but didn't change anything. And btw I am playing specifically with Assetto Corsa for this.

Thanks for looking.

Comments

  • SPR is not working in any game other than Forza Games.

    You should avoid any dampers like NDP, NFR, NIN and then it should be possible to Drift very easily.

  • Yeah I tried that but didn't work. So basically I turn the wheel clockwise say 520 degrees and let go of the wheel and I am expecting the wheel to auto rotate back to the left (counter clockwise) but it isn't doing that. It just stays in place.

  • Yeah that's normal.

    Only when you are actually in game and driving then the wheel will not stay in place but on the Desktop it's intended that it stays in place.

  • I am talking about in the game.

  • Hi Roy,

    When a wheel stays in place it sounds like there is no force feedback response at all. Check that you have:

    • The Fanatec Driver correctly installed.
    • At least 40% Gain in the AC force feedback menu
    • At least 30% FF in the Fanatec Tuning Menu
    • FOR at 100 in the Fanatec Tuning Menu
    • A low NFR setting

    If it still isn't responding then I suggest you create a video to show us exactly what it is happening.


    [Fanatec Community Manager]

  • Hi, yes I have checked all those things already.

    I can feel the force needed to steer the wheel. Doesn't that already means there is force feedback?

  • Ok I found the issue. For those experiencing this. I am using the WRC wheel with the Podium DD2. Apparently, if you're using that combo, you need to put the wheelbase into Comp v2.5 mode instead of PC. I am unsure why that is the case but it seems to work once I put it into Comp v2.5 mode.

    I hope that helps someone else out there.

Sign In or Register to comment.