Wireless Quick Release Update Mode Error: Connect device failed(Error: Initial ping failure:...)

Good afternoon,

 somebody have some insight about if fanatec are caring seriously about the issues they are having with his podium wheelbases and the problem:

'' wireless update mode...initial ping failure error''

It's being quite serious as I have been seeing recently more people speaking about it, and probably not everybody is advertising about his problems.

my case is next one:

DD1 buyed in april 2019, everything right for 2 years , but last week suddenly wheel failed and appeared the problem of wireless update ping failure blabla...

I open a ticket, fanatec reacted fast, one day. They send me a RMA to send wheel to fanatec warehouse. Next day wheel travelling to be repaired ( I suppose that will be repaired as no more explanation by fanatec in the email)


Was a pitty but it's OK and understanble. At least seem that they response fast and without questions ,so probably they already know about this problem being frequent. But is not very clear if this will be for days, weeks, months..no explanation. But again , understanble as it's ap roduct with two years of use and 'shit happens'.....you know.

 Then I was thinking that DD1 will be out for reparation for some weeks or whatever, I decided to buy another wheelbase,a DD2 that appeared in stock in fanatec web. So in this way I will have a second wheelbase, and also I will not be without wheel for some weeks/months.  

Today the DD2 purchased last week arrived, I mounted, and I shut ON ...and surprise, same problem as my old DD1 appeared in his first plug.

I tested everything, different computer,usb ports,firmware old and new....nothing work. This new DD2 arrived with same problem then the old DD1.

Really disappointing and sad.

I think that even though the answer by fanatec is good, as it seems that they are caring of the problem with his customers, this is not normal in a new product , and a very dissapointing situation for the customers, and the most important is that seems a problem not solved and not controled.

I always belived in fanatec ecosystem,but this is too much. 

After this problem , I open a ticket to make the return of this failed DD2 and have asked for a refund of this purchase that arrived broken.

let's see how it evolves.

 anyway I'm sad of the decision, many years with fanatec ecosystem , but this is too much, and in the past there were other RMA also of other products .

best luck for all customers and sorry for the little rant. 😪


  • You would think it's the PC. Because that's the one i would suspect when having 2 individual products that fail having one common denominator (the PC).

    Some ideas to test out (do with it whatever you want),

    • Try it on another pc (you already did)
    • Try to find out if any software or driver had an update recently (Windows update once messed up my drivers also, same goes for an nVidia driver). Also, just pick the 381 driver as a start, https://forum.fanatec.com/discussion/21631/fanatec-driver-381-release-candidate-for-csl-csw-and-podium-bases-all-wheels/p1 (and yes there is a newer version but that one has the new and shiny update manager and although i personally didn't have issues with it the users with issues is way to big)
    • Disconnect all other hardware other than the wheelbase
    • Close all other software that is running (Simhub, Anti virus etc)
    • Try to see if the problem occurs when no wheel (and pedals if you connected them thru the wheelbase) attached to the wheelbase
  • Hi 

    thanks for your tips Reind, really appreciated.

    and I agree with you, seems absolutely strange. And for some moments I was thinking a problem on my own, but i'm pretty experienced about firmware,software and hardware , and also was pretty sure that I'm doing all fine .

     In fact, i'm being kindly attended since 2 days ago, by Alexander from fanatec technical service, and we have tested a lot of variables and many things to try solve the problem .

    With 2 other different computers, without other devices conected, no antivirus ,no defender , firmware, 381...a lot of things tested that kindly technical service have asked to me to be done.

    nothing worked.

    finally ,since an hour ago a refund RMA is open and DD2 will come back to fanatec. 

    was a pitty, but after all time lost,all things tested, and the frustration conseqcuence of this, it's the best for all.

Sign In or Register to comment.