DD1 firmware update problem: Wireless Quick Release Initial Ping Failure - Potential Solution?

Hello all,

Note: I will likely ramble a bit due to the horrific experiences I've had dealing w/ Fanatec to date, so if you just want the potential solution scroll down.

The Airing of Grievances:

I recently purchased the Podium F1 wheel + DD1 base + CSL V3 pedals (received them all yesterday) and so far the experience has been nothing short of a nightmare. When installing the latest driver software (402) and going to the properties page I was prompted to update the base firmware. That seemed to work just fine. Then it prompted me to install new firmware for the Wireless Quick Release. This installation appeared to fail with the dreaded "Initial ping failure" message. I googled this and found several forum posts here describing this problem, steps attempted to troubleshoot, and ultimately RMAs being issued for this problem.

I attempted to uninstall the 402 driver and install multiple older ones (one at a time) with the base connected to a USB2.0 port instead of a USB 3.0 port. Attempting to go through the update process seemed to provide different errors depending on the version I was using, but ultimately nothing I tried worked. As a result I filed a support ticket w/ Fanatec and was immediately offered an RMA and told that I'd be responsible for paying taxes/duties on the new unit.

I'm from Canada, and ordering directly from the Fanatec US webshop. When I placed my first order initially, I accidentally selected a desk mount that was incompatible with the DD1 base. I realized my mistake within an hour of the purchase as I was reading through the tech specs of the parts I ordered. I ended up cancelling that order and placing a new one w/ the appropriate desk mount. Instead of simply cancelling the initial credit card authorization, Fanatec decided to bill me for it, then to do a separate transaction for the refund. As a result I got screwed out of over $150 due to the exchange rate difference. I would have expected this had I not cancelled my order so quickly - pre-auth transactions post in ~ 24-48 hrs so after that time I realize there's no choice but to issue a refund instead of cancelling the original transaction. That said, my cancellation (and the refund transaction) were well within that time window. I don't know why this is their process for cancelling foreign currency transactions, but I'm hoping somebody who can do something about it reads this and realizes how infuriating it is to hand over $3000.00+ local currency and get screwed out of an add'l $150+ just because of the way you guys process your cancelled orders.

Moving on...

Potential Solution:

After submitting my support request I kept reading through other forum posts until I came across this one: https://forum.fanatec.com/discussion/comment/67664#Comment_67664

Fortunately, I have a stack of old laptops as I had to go back a few generations to find one with a USB 2.0 port on it. The laptop is an old Lenovo that I haven't booted in years, and still has Windows 7 on it. I installed driver version 381 on this laptop, plugged in the wheel base, and all of the firmware updated successfully - albeit to slightly old versions being that the driver is a few versions old. The wheel finally showed up in the Wheel Property Page and allowed me to perform function tests, calibrations, etc. It also showed up in FanaLab.

On my main PC that I plan to use the wheel on, I uninstalled the Fanatec driver, and installed the 381 driver and rebooted. I plugged the base/wheel/pedals in to my new PC and suddenly everything worked beautifully. I've only gotten to use it for ~ 30 mins since, so I've got no idea if this is a permanent solution, or whether something will go wrong after a few hours use, but I will make every effort to come back and update this thread after a few days use.

Confusion:

All that said, I'm now really confused. The fact that I got the wheel working and updated using an old laptop, with an old OS with USB 2.0 ports seems to suggest that there's no hardware problem with the wheel/base at all, but that the problem lies either with the drivers, or the firmware updater/bootloader. My questions to Fanatec staff are the following:

  1. Since this issue has been talked about SEVERAL times in these forums, and they almost all result in an RMA - what specifically is the hardware issue that needs to be solved with the wheel? I'm not keen to RMA this thing, and having to pay for taxes/duties AGAIN because YOU sent me a defective product unless I'm certain that the issue will be fixed when I get a replacement unit. If someone can respond to this with specifics it will go a long way to reassure me that you actually know what you are doing and that I won't simply have the same problem w/ the replacement unit. I noticed that the previous posts that all suggest they got an RMA are suspiciously void of any update as to whether or not their replacement unit worked when they got it.
  2. If this is some known problem (which it appears to be based on the volume of forum posts here, and the fact that the support team immediately issued an RMA vs. attempting to do some troubleshooting) why are you still shipping bases with these defects? If you understand the problem why aren't you fixing it (or testing for it) before shipping these units out? Shelling out over $3000 CAD for your products, only to have them arrive possibly defective in combination with my previous order cancellation experience has left an incredibly sour taste in my mouth.

My thoughts:

These are only my thoughts and, admittedly, could be entirely wrong.

When I first placed my order I thought I was buying a premium product. I've since been given the impression that Fanatec is a few people working out of a garage. I imagine they're really good at manufacturing because the physical build quality of the products are amazing. Unfortunately, it feels like their software/firmware development was outsourced to Fiverr.

I see posts full of issues and the blame being put on "the computer" and advising people try another computer. This makes my head spin. It's NOT a problem with the computer, it's a problem with trash software/drivers. I'm very much looking for confirmation from anyone on these forums that they've run into the same hassles, tried this solution, and had a working wheel for a good length of time. The absolute last thing I want to do at this point is interact with Fanatec in any way, so if I can get away with avoiding an RMA based on a stranger's report that their wheel is still working after this I'll trust that over Fanatec support. Honestly, this whole experience has me so infuriated that I'm as likely to destroy the entire kit with a baseball bat and put the video online vs. spending another penny on taxes/duties and another minute of my time dealing with Fanatec support.

Comments

  • What makes you sure it's not a problem with your main computer when you say you were able to update successfully on a different computer? If I was in your position I'd be checking USB drivers and settings on the computer that had issues.

  • Occam's Razor. What's more likely? That LOADS of Fanatec customers have all kinds of wacky USB port driver problems? When USB is an old well established standard with reliable drivers that run basically every other peripheral plugged into them, the odds that there's something wrong w/ those drivers I'd say is pretty damn slim.

    If Fanatec software/hardware can't run on USB 3.0, errors out all the time, does goofy stuff like setup a COM port over USB configured with a baud rate of 9600 when the updater software throws error messages showing it's attempting to communicate at 19200, and has UI that looks like a 90's geocities page - well, I can't be 100% certain - but I'd definitely be willing to bet that the same sloppiness in the visible pieces of their software is even more pronounced in harder to develop things like their specific device drivers and their ability to make those drivers compatible with newer operating systems / technologies - not to mention their firmware.

    If it's between blaming my brand new top of the line Alienware gaming PC that runs literally everything else I've thrown at it perfectly (as well as the individual PC setups of everyone else on this forum that has problems), vs. this one-off product with forums full of people with issues, my inclination is to ignore the excuse makers blaming individual's PCs, and put the focus on sloppy devs @ Fanatec.

  • Follow-up:

    I just played F1 2020 for 4-5r hours straight. Absolutely no issues. Everything is still working perfectly.

  • Some users have issues with the drivers on their PC but the majority do not have issues with drivers on their PCs. You yourself had no issues on a different PC. I don't follow your logic - Drivers work on one of your PC's but not on another and you blame the driver. If you had a lightbulb that worked in one socket and not another socket Occam's razor would suggest the problem is with the second socket - not the lightbulb. :-)

  • Please stop. I'm trying to provide actual useful advice for people who are also having this issue. If Fanatec really thought it was an issue with my PC's drivers they wouldn't have offered to do an RMA right off the bat, then sent a follow-up email explaining that this error message is due to a hardware problem.

  • Status Update:

    I uninstalled driver 381 from my old laptop, and installed 402, re-connected my wheel base to it and it actually managed to successfully update the firmware. I did the same on my gaming PC - uninstalled 381 and re-installed 402, plugged the wheel in and everything works fine now w/ the latest drivers. I have no idea why things didn't work the first time (well, first several times...), but it appears I saved myself $250 on taxes/duties on an RMA that probably wasn't necessary. If something goes wrong in the future I'll update this thread, but $diety willing everything will work fine and this is the last anyone on this forum will ever hear from me .

Sign In or Register to comment.