Clubsport wheelbase V2.5 no longer working in game.

The wheel was working fine, then after a race on Assetto Corsa it would no longer register any inputs in the game. On the controls setting screen it shows my wheel, all the inputs work. I can remap the buttons, but as soon as i load up a race it just doesn't work. I tried raceroom with the same outcome. It still works normally on the Xbox one. I tried uninstalling and reinstalling the driver 356, and restarting my pc. Fanalab and the game controller box shows my wheelbase, but i cant access the properties. An error message appears saying "There is a problem setting up the wheel control panel. Please reconnect the device and try again"

I emailed Fanatec, but i figure they are probably swamped with support questions so I figured I would ask here as well


  • Try a different USB port (best is USB 2!) and try to repair the driver.

  • Thanks for the response. I tried all the usb ports but still nothing. Went to driver 347, changed ports, and now its working again. Its been very frustrating.

Sign In or Register to comment.