Issue with DD1

Hey all, i have new out of box DD1 that i am getting the below issue with, is there a solution for this?

I have tried 3 different machine and all usb ports on my rig with no change to the error, help?

Wireless Quick Release Update Mode

Error: Connect device failed(Error: Initial ping failure: No response received for ping command.).


  • Hi Robert,

    I just had a chat with Luz of Fanatec Support. Good support by the way!

    I have the same error message. Did you get your wheel base up and running again? Or did you had to send it to Fanatec support?

    After the bootloader procedure I constantly get the same message.

  • Nope not up and running, i have RMA but still waiting on the details to be able to send it back, Luz was great, i spoke with him last night via live chat, just seems to take a while before any movement happens, which may be due to being in Australia, which is a little frustrating

    Good Luck

  • Thanks for your reply Robert. Upon request I uploaded a video with the DD1 error symptoms. Now also waiting for a RMA (based in the Netherlands). Meanwhile I reinstalled my older CSL Elite...what a difference with the DD1. #spoiledme

Sign In or Register to comment.