CSL DD Issues

I am sure that some of these issues listed have been mentioned previously but I am really struggling to get an official statement on how or when these will be fixed. Also have an issue that I havent seen elsewhere.

My issue: Since getting my csl dd when I power up the base I get static in my headphones, most likely due to EMI. I am using a behringer amp, and beyerdynamic dt990 pro headphones. This is bearable when driving as the sound of the game overpowers the static and also when moving the wheelbase the static will change frequency and sometimes cut out altogether, but when sat still it is headache inducing.

Other issues: H pattern shifter no longer calibrating through usb or direct through the wheelbase.

Clubsport v3 pedals do not show up in firmware 410 or in fanalab for any adjustments.

When swapping my wheel rim from my mclaren gt3 rim to my universal hub I found that the tuning menu in the wheelbase was not showing up on the display but the speedo and gear selection was. When in a car if i press the tuning menu button the screen would turn off and then when pressed again it would show my speed as normal.

Other than these small (ish) issues the wheelbase does feel great and definitely a worthy upgrade from my csl elite 1.1


  • all the issues you have raised are know issues right now with the CSL DD. I'm experiencing the exact same with the exception of the static. That I have not experience at all, though my sound is coming out of the HDMI port rather than from an onboard soundcard.

  • John ReggioJohn Reggio Member
    edited August 2021

    I received my CSL DD two days ago After a nightmare of transferring the new base to my rig, it worked fine Then this morning when it booted up, there was no power to the wheelbase. The blue light on the Boost Kit 180 was on, but no power to the DD. i checked all connections and they were fine. Originally I downloaded the driver before even turning on the DD. I sent a problem notice to Fanatec, but they take forever to answer. If anyone has an original solution, that would be helpful. I'm a 77 year old man with limited computer skills. I don't want to rebox and return the unit, but I'm not sure what to do now.

  • I've noticed you have to hit the power button on the base after every boot, (bottom right corner of the base, where the light was while it had power). I'm also an old fart, and these things are not set up to be user friendly at all.

    The control panel not saving profiles and having no option to minimize is also bogus.

  • yea maybe its already solved but you can hold the power button in for 8 seconds for the bootloader menu , you can reflash the base there

  • Thanks Jason and Dave,

    Thanks for the help. I originally held power button down for 10 seconds as Fanatec suggested, but that did nothing. There's just no evidence that the power is being received even when I held it down for 20 seconds. NO bootloader menu. I erased all the driver files and reinstalled them (both 410 and 411) Another exercise in futility. Now I'm waiting for Fanatec to read my email and send me an RMA so I can send the damn thing to them to fix. Aargh!

  • Kudos to Fanatec! One day after returning the CSL DD, Fanatec informed me that they would by shipping out a new unit immediately. It arrived in five days and all is well. New unit works flawlessly. Thank you Fanatec for your prompt actions.

Sign In or Register to comment.