newbie question....DD2 and low torque confusion

I have searched high and low for what I hope is a simple answer but led to more confusion.

I have a BMW GT2 wheel, v1, I just upgraded from the CSL wheel base to the DD2. it says "hit ok to enable high torque" I have no idea what button it wants me to hit. but then on occasion it tells me that the quick release reduces torque to low.

I assume this means my wheel cannot handle the torque with the quick release. I have been unable to confirm. Assuming it is the quick release what are my options? which wheels do support high torque? I do not want to spend $$$ and have the same thing. what in the heck am i missing here? thanks.


  • Thanks still not working, works with my old indy wheel but not with the BMW GT2 wheel. tried the violet buton..(and all the others) tried turning it to 90 degrees, nothing. so half way there :( but my round wheel still not great.

  • Some wheels limit torque. Some wheels can be upgraded to the metal quick release to enable high torque. ALL wheels require you to hit the "X" button (it's the "A" button on Xbox wheels) to enable hi torque.

    There are wheels like the WRC that lock out hi torque. I don't know about the BMW wheel. I know the McLaren wheel is low torque until you upgrade the quick release. The FAQ should tell you what's compatible.

  • What driver version have you installed?

    There is an issue with V411 that for some a simplified QR is recongnized although the metal one is installed. Thus, only low torque mode is available. As there is currently no solution, you could downgrade driver and firmware to V402, then it should be working the usual way ("ok" button or 90° turn to accept the low torque warning).

    If you don't have v411 installed, there must be something else, as the BMW GT2 wheel is capable of high torque.

  • UPDATE: I got an email from Fanatec Saturday stating that it is a bug in the current firmware. So FYI for those on 411.

  • I'm experiencing the same issue with my BMW GT2 wheel. If I update to the latest driver it only allows low torque.

    However, my formula v2 does not work properly with the previous driver. I do have the advanced paddle module installed, which may or may not be the thing that is actually not working.

    Either way, I cannot use both with the same driver, this is not really acceptable, fanatec needs to fix this.

Sign In or Register to comment.