CSL Elite Wheel Base - motor stops, power light flashes red.

CSL Elite with xbox wheel on PC with iRacing

PC Driver: 347, Wheel base Firmware: 664, Wheel base motor firmware: 22

I am having an issue with the wheelbase motor stopping and the the red power light flashing after 15 minutes of use, sometimes longer. The wheel still turns in game but there is no FFB or resistance.

I have re-installed the drivers and flashed the firmware on the wheelbase/wheel but the issue still remains.

I have contacted support and their suggestion was to re-install drivers etc. which I've done multiple times.

Is there anything else I can do to troubleshoot? I am growing increasingly frustrated with this hardware unfortunately.


  • Mine did this olso with the formula V2 and both are returned to fanatec. Still warming for new one..

    Good luck, feel the frustration..

  • I tried reinstalling the firmware again on the wheelbase. Took a couple of trys as the update seemed to stall. The wheel base worked great for a couple of days but again last night the FFB failed mid race.

    I've tried different things within the game like power cycling the wheel between qual/race sessions or whenever exiting iRacing and going into a session, but with no clear results.

    Is there anything else I could try here that may help with this issue?

    What could be causing this issue with the wheelbase? Would it be something physical failing in the base, wiring or a sensor?, or fanatec software/firmeware, could it be something external like the PC or even iRacing?

    This is quite frustrating as the wheelbase worked for a few months before these intermittent FFB shutdowns started and now each time I start a race I have it in the back of my mind that I may suffer a mechanical failure.

Sign In or Register to comment.