Fanatec Firmware Update Error - Connect Device Failed

Good morning everyone,


I recently updated my drivers ( after having literally no problems with my DD1 over the past 2 - 3 years ), and 2 weeks later when I plugged my DD1 in, initially the PC recognized it but then the Firmware update page opened automatically, and is displayed showing this error about pings. Now, the bootloader still works, and I am able to flash the base different base hardware, however I also noticed that on boot up, after the base shows the fanatec logo and rotates the wheel - the display goes all black, and generally that is when the Firmware Update window opens.


I've tried loading different bootloader firmware, but that is all I seem to be able to do, as the wheel is never recognised by the PC, prior to this firmware updater opening and claiming an error. I've tried this on 2 different PC,s and on several different USB ports. even the USB port in device manager is re-named to fanatec updater ( Com 6 ) for example........ Is there a way to force the base to load all factory default firmware ( base / motor / and wheel ) ? and then I can try and update from there ?


Comments

  • Joseph GossenJoseph Gossen Member, Moderator

    Hi Michelle,


    You will need to open a support ticket to have this repaired.

Sign In or Register to comment.