CSL DD / McLaren v2 suddenly becoming unresponsive while in game?

I'm curious to know if anyone else has experienced anything like this, and if so, what some possible solutions might be. Basically, here's what's happening:

I'll be playing a game, and while in the middle of driving, all of a sudden the wheel (and pedals) become completely unresponsive. Brakes don't work, steering, buttons on the wheel, all dead, invariably ending in a catastrophic crash. Sometimes I'm able to Alt+F4 to kill the game and reboot, but other times even the keyboard and mouse have been unresponsive (couldn't even Ctrl+Alt+Del). It's happened in multiple different games, so I don't think it's a game compatibility issue.

I've tried all different USB ports, to no avail. Just when I think I've solved it, it happens again. (It happens maybe once or twice a week, and I use the wheel pretty much every day).

I thought maybe it could be an issue of my PC overheating? The back does feel pretty warm when it's in use, but I wouldn't say it's scalding hot. Usually though, after a restart, I can go ahead and play for hours without it happening again, so that kind of leads me to believe it's probably not a heat issue...?

If anyone has any ideas or suggestions, I'd appreciate it.


My setup:

CSL DD

McLaren GT3 v2 wheel

Clubsport v1 pedals, connected to base via RJ-12

Simple QR Adapter

Driver 411

Wheel Base Firmware: 1.0.2.4

Wheel Base Motor FW: 1.0.1.3

Steering Wheel FW: 41

Wireless QR FW: 6.0.0.1


PC Specs:

Processor: Intel(R) Xeon(R) CPU E5-1660 0 @ 3.30GHz  3.30 GHz (6 cores)

Installed RAM: 16GB

Win 10 Pro 21H1

Radeon RX 570, 8GB

Comments

  • The CSL DD manual did recommend only 1hr continous use of wheel. I know most will exceed this easily.

    Have you tried some form of ventilation for the base?

  • Gregg DomainGregg Domain Member
    edited October 10

    One hour of continuous use seems pretty absurd. The only thing I was able to find regarding that was the following from the manual:

    "Excessive use may cause health risks. We recommend taking a 5 minute break after every 20 minutes of use, and to not drive for more than 2 hours per day."

    ... but that seems like pretty standard health & safety lingo, not something that means "our product may not work correctly if used for more than an hour or two."

    I've downloaded some software for monitoring temperatures and running stress tests, so we'll see what comes of that.

    For the record, it just happened to me 3 times within the space of about an hour or so of playing Dirt Rally 2.0.

  • Ok, so I've downloaded AIDA64 and have run its System Stability Test for the last 75 minutes or so.

    It's showing my CPU Temps as:


    Min: 49C

    Max: 84C

    Avg: ~77C


    GPU Temps seem to be in the area of about 74C.

    I *think* these temps are ok, from what I can gather...? I do have a small-ish external fan that I could try placing in front of the case to see if that does anything to help bring temperatures down...? Worth a shot, I guess?

  • It says under section 1. General,

    The recommended operation time with continuous force feedback activity is 1hr.

    So no races of more than 1 hr? hahaha...


    I do not expect it to happen even once at all. But you did mention that your keyboard and mouse did not work either sometimes. Is your power supply enough for your setup?

  • Oh wow I totally overlooked that. Still...I'd expect that to be more of a health & safety precaution for your own well-being, as opposed to a warning that your hardware is likely to malfunction after more than 60 minutes of use. But what do I know? 🤷‍♂️🤔

    That's a good question re: the power supply. My friend who's an IT guy helped me put the system together. I'll have to get in touch with him and see what he thinks. Thanks for the suggestion.

  • Have you tried turning down the graphics down to low, just to see if it happens again? Sounds to me like it is the game "freezing", the fact that you lose keyboard functions as well.

  • I haven't adjusted any per-game graphical settings, but I may give that a shot just to see.

    May just be coincidence, but I've been blasting an external fan at the case, and CPU/GPU temps have been staying in mid-upper 60s to low 70s during gameplay for the last 30-40 minutes. I'll have to test more, obviously, but... no crashes/ lock-ups yet...🤞

  • Question are you using a usb hub ?, it’s possible that the computer power draw is overwhelming the usb, the wheel should not have any affect on other devices plugged in, unless the power draw is excessive, I use a separate card for my wheel base and my x56 hotas as it draws way to much power from the 12v power rail, and I have an 850w gold supply.

  • Well , even DD1 and DD2 has same general raccomandation....

  • Gregg DomainGregg Domain Member
    edited October 10

    No, no USB hub. I have USB ports front and rear (which as I understand, the front ones are from a card whereas the rear ones are on the mobo itself). Front and rear each have one USB 3.0 port (blue), and I believe four standard (white...2.0?) ports. I've tried plugging things in only in the front ports, only in the back, and different combinations of the two... all to no avail.

    PSU that's installed is 635W. My friend seemed to think that would be enough. Maybe it isn't?

    In addition to the system specs I listed in my first post, I have two 500GB SSDs installed. Plugged into USB are a standard keyboard, wireless mouse dongle, and an Xbox One Controller. Monitor is a 37" Samsung TV.

    Could all this plus the CSL DD be too much for the PSU? How could I determine if that's the case?

  • Ok so we need to start a process of eliminating if it’s hardware or software, dose it happen when playing game’s without the wheel base plugged in, also are all your drivers up to date, and your chipset, and Gpu drivers correct, the psu seems to be man enough, so I don’t think it’s that, so first check the drivers for the system also open device management and check there’s no warning ⚠️ showing, and check the ssd’s in administration to make sure there’s no issues with the drives first then we can look at other items.

  • The CSL DD is not taking power from your PCs PSU, it's plugged into the mains so that's where it gets its power from.

  • He can't be overloading the electrical power supply to his base can he? I mean by connecting his pc and whatever else to the same wall scoket ring in his house? That will trip the circuit breaker instead isn't it as opposed to making the electrical supply unstable hence cutting power to the base intermittently.

  • I think I may have stumbled onto something tonight. I was playing DR2.0 and things were going great. CSL DD was in PC mode.

    I then went to play some F1 2019 (switched the base to CMP mode), and nothing was showing as being detected in Fanalab. No base, no wheel, no pedals. After several restarts, powering the wheel off and on, opening up of control panels, etc., I was starting to lose my mind, as I had played the game on previous occasions with no problem.

    Something told me to change the USB port that it was in. I did, and upon plugging into a different one, (with the CSL DD still powered and in CMP mode), everything was immediately detected in Fanalab.

    So... this led to me checking every USB port by plugging the wheel in, both in PC and CMP mode, and noting what is then displayed in Fanalab. I shut down and started up several times to verify, and here's what I found:

    • PC Mode: All USB 2 ports seemed to function correctly, and wheel, base, and pedals were detected in Fanalab.

    • CMP Mode: (1) USB 2 port would consistently display nothing in Fanalab. Switching back and forth between PC and CMP modes would toggle whether the gear was detected or not.

    • Note on USB 3 ports: Seemed to depend on which mode the CSL DD was in when first detected by the system. If booted in CMP, everything would show in Fanalab in CMP, but only pedals were detected in PC mode. And vice versa. Not 100% sure of this detail, but I don't particularly need USB 3 for any of my peripherals, so I'm not overly concerned.

    ---------------------------------------------------------------

    TL;DR

    It seems I've got a bad USB port, at least as far as Fanalab and my Fanatec gear are concerned. What's strange is other devices like my KB+M will work on that port (as will my Fanatec gear in PC mode), but in CMP mode, that one port is a no-go.

    I'm going to try avoiding that port altogether, along with the two USB 3 ports just to be safe, and try plugging everything into other ports to see how things get on.

  • Cheers for that! That is really good to know. 👍️

    Software and drivers problems would have been such a headache! Changing USB ports is so much easier, irritating yes but at least it works.

  • Well...so much for my theory. I avoided the bad port, played some F1 2019 for about half an hour, and it happened again. 😫

    Same thing: wheel and pedals went unresponsive, I lost all control, throttle was stuck open, I wound up with a face full of armco.


    I powered off the wheel, and I was able to Alt+F4 out. Upon turning the wheel back on, only the base and pedals were detected. So I checked the wheel, the QR seems solid. I pulled the wheel off, all the pins seem fine, reattached it, tightened the QR. All seems good there, far as I can tell.

    I'm wondering now if it's the wheel and/or wheelbase itself that's the problem. I've been running driver 411 since I first got this setup...I guess I'll try 415 and see if that makes a difference.

  • Update:


    I've updated every possible driver through Windows Update, installed the latest Radeon drivers, updated to the Fanatec 415 drivers, and after 15-20 minutes in DR2.0, it happened again: complete loss of input from the wheel/ pedals.

    The game doesn't crash when this happens, it carries on as if everything is normal. What I did was power off the wheel, which caused the game to pause as no input device was detected. I changed the wheel to a different USB port and powered it back up again. The game recognized there was once again an input device connected, I unpaused, and was able to carry on like nothing had happened (despite now having a heavily damaged car).

    I dunno man, I don't get it. It's clearly not a game issue, as I've had it happen across multiple titles. I don't think it's temperature related, as all temps are within normal operating values at all times. There does seem to be something funky going on with that one USB port that doesn't recognize the wheel in CMP mode. I made sure not to use that port, but the issue still happened. That port is in the rear of the machine. I'll try avoiding rear ports with the wheel altogether, and see if that makes any difference.

    I feel like I've done this all before. What's the definition of insanity again? 😣

  • The last dreaded option ... contact support... RMA... sorry to hear that if support is not able to solve the issue.

    I feel you dude!... I would not want to return my unit as I want to find a solution so I can continue using it!!!

  • Long shot but is there a possibility that your USB port going to sleep mode after some time?

  • Gregg DomainGregg Domain Member
    edited October 13

    Maybe...? I hadn't thought of that, thanks for the idea. I had no idea that was even a thing. Found a quick tutorial, and turns out Windows has the ability by default to put USB devices to sleep, so I turned that off. Hopefully that won't cause any unanticipated issues...? Lord knows I've got enough of those already. lol

    Good news is that I was able to put in about 2-3 hours of DR2.0 tonight, and no issues. The rear of my PC has 6 USB ports, broken up into 2 on the top and 4 near the bottom. The one that was giving me issues with the CSL DD when it was in CMP mode is one of the upper ports. On a hunch, I didn't plug anything into either of those upper ports. And like I said...so far, so good. Fingers crossed...

  • David ChiengDavid Chieng Member
    edited October 13

    Yeah... found under one of my Universal Serial Bus Controllers, under Device Managers, has a power management tab and it is set by default to go to sleep to save power... under... USB root hub 3.0???


    So which USB ports did you use for the CSL DD base? 2.0 or 3.0? Did you mean you chose to use only a certain type of USB ports at the back?

  • The cable that comes with the CSL DD is USB 2.0 (white tip), so that's what I plugged it into (in one of the ports on the front of my PC).

    The rear of my PC looks like this:

    The USB port in the upper left (as we're looking at it) is the one that wouldn't recognize the wheel in CMP mode. So I made sure not to plug anything into either that port or the one to the right of it. (I'm not sure of the inner workings of the motherboard, or if those ports are somehow related in the sense that if there was an issue with one, the other might also be affected...but I figured it's worth a shot.)

    In fact, to keep things as simple as possible for testing purposes, the only USB devices I have plugged in are the wheel and a keyboard (both in ports on the front of the computer), and the little Logitech wireless mouse dongle you can see plugged into the far bottom right port in the pic.

    I'm cautiously optimistic that avoiding that pair of ports will do the trick, since by doing so I was able to play tonight with no issues. Just have to wait and see now.

  • So if that is the case then it is just something to do with your USB ports/motherboard and how windows is handling those USB ports... what a ffaf!!! 🙄

  • 🤞🤞🤞🤞🤞🤞🤞

  • Knock on wood...another 3 or so hours of gaming tonight, and no issues to report. I don't want to give it the commentator's curse, but I'm starting to become hopeful that maybe we've finally got this thing figured out...🤞😬🤞

Sign In or Register to comment.