Brand new McLaren GT3 V2 right shifter/paddle not working (stuck on pressed) (EASY FIX?)

Yesterday I received my DD CLS bundle (after a long wait) and I was thrilled with everything being such high quality and relatively easy to install.

Unfortunately, my excitement quickly dimmed when I realized that my right paddle shifter did not register on ANY of my racing sims. And when I looked at the Fanatec control panel, it also showed it being stuck. SEE PHOTO. No amount of clicking seemed to make a difference.

I contacted customer support, but I was wondering if there's an easy fix because it looks like a mechanical problem (no bent pins and everything else works as it should).

Any suggestions for non-warranty-voiding things I can try until I hear back from customer support?

Thanks a bunch!


  • Do you have a solution yet? I got the same problem with a ClubSport Formula V2.5 X, every button is working except the left paddle.

    edited November 2021

    Sorry. No easy fix. I'm going to have to send it in for repairs. I wish they'd offer to send me a replacement wheel. Because it came with that defect right out of the box.

  • This may void your warranty, but you can remove the silver pin on top and remove the orange paddle assembly. There is pads that push into the limit switch and they can come off center causing this issue.

  • I got the same thing happen to me on my formula v2.5 , left paddle is stuck, on a brand new CSL DD too , how did you contact fanatec ? Or start a ticket ?

  • I contacted Fanatec customer support the very same day I installed the wheel and noticed the problem immediately.

    They asked me for a video to show the problem on the Fanatec app, and I sent it to them. All other buttons worked, except the right shifter and the video shows it clearly.

    Since it was a brand new wheel and a manufacturing/QC defect (it didn't work out of the box), I asked them if they could send me a replacement wheel rather than have me wait weeks without a wheel waiting for shipping time, repair time, ship back time, but they refused. Which I found disappointing because I could have just returned the wheel for a full refund.

    So, for now, since I already waited months for my DD CLS and I want to enjoy it a bit more (and not go back to Logitech's wheel) I mapped the L/R shifter to the two top buttons which I can reach easily with my thumb and I will eventually send it in a wait ... :-(

    Bottom line: great product and design, but disappointing QC and disappointing customer support.

  • try what fesenko recommended.

    there is something on youtube too.

    search... how to quieten the shifter activation.

  • found it... check the pads.

  • Thank you all for the suggestions. I love how we help each other with these ingenious solutions (yes, the shifters can be loud if you are racing and the household is sleeping :-)).

    I've noticed that my problem with the right shifter has become intermittent. In other words, when I first start it's stack but, somehow, after some time racing (using the top two buttons as shifters instead of the paddles—which works GREAT, BTW—the right paddle starts to work properly, at least for a while.

    Question: IF the problem is a misaligned pads, why/how could using the wheel for a while fix the issue? Judging from the videos/photos it looks like an all or nothing situation. Meaning, if the pad is off then it won't work.

    I mean, it would be great if this simple fix worked, but since would void the warranty ...

Sign In or Register to comment.