Clubsport V3 Pedals Intermittent Throttle Issues

Max348Max348 Member
edited November 12 in Pedals

Brand new out of the box I am experiencing intermittent throttle issues. First lap or so everything feels ok, however, lap two and so on the throttle begins lagging and at times sticks. When it lags the throttle position stays constant and then all of a sudden, it spikes up to where the pedal position currently is. When it sticks... well that speaks for itself. Basically I exit the track at a high rate of speed! The issues seem to present more often during cornering and when throttle finesse is required.

The mechanical pedal movement is smooth and does not appear to be binding in anyway. I have removed the assembly from my rig and have attempted to blow out any debris that may have been present with compressed air. As per the FANATEC website, I have attempted to uninstall / install the drivers. I have checked the wiring connections and everything appears sound. The three (3) bolts attaching the sensor to the throttle pedal were a little loose, so I snugged them up. I have tried different configurations in the tuning menu (setting min & max pedal travel, etc.). At this point, nothing has helped.

The above is all iracing (only sim i have right now). I have emailed support, however they have requested a video of the malfunctions before they can look into it (ill send one to them this evening).

For now, has anyone experienced issues like this or have any recommendations for fixing it. I have waited three months for my set-up & am pretty bummed to say the least...

Thanks in advance

Comments

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Max,

    That sounds like some kind of interference. Have you tried grounding your rig?

    Please contact support for the best advice. You can contact them by creating a Support Ticket via the My Products section of your Fanatec account, or you can try the Live Chat feature, open Monday to Friday, 8 to 11 a.m. and 1 to 4 p.m. (CET). Live Chat is active whenever you see the headset icon on the site.


    [Fanatec Community Manager]

  • Do you think zip-tying the USB cable to the power supply would cause the interference issue?

  • Dominic BrennanDominic Brennan Member, Administrator

    It shouldn't, it is common for people to route multiple cables together. But it is something you could test.

  • Ok, thank you, Ill try running the USB differently tonight.

    As far as grounding goes, my rig is primarily PVC - how would I go about grounding it?

Sign In or Register to comment.