problems with base dls dd

1- from the first day the wrc steering wheel is not recognized by the base, I cannot configure the buttons on the steering wheel, the LEDs do not light up, (tried both dirt rally and rbr world) the steering wheel tried on a fanatec station of a friend of mine, and the steering wheel works ........ 2 after a few days of testing, the csl dd base does not turn on anymore, tried your suggestions several times, to no avail ....... I practically haven't been able to play yet ...


  • give the forum as much details as possible for them to help you. mode, settings, what firmware, updates that you have done or not done or done and not work, what is plugged to whatelse, pheripherals, pc, usb etcetc. pictures.

  • edited November 2021

    good evening everyone, then these are the requirements of my pc

    the second photo are the connections I made, the pedalierav3 connected directly to the pc, the handbrake, I still have to install it

    the third photo, the first installation, the program recognized everything except the wrc steering wheel .......... you can also read the drivers and firmwares

    the fourth photo, after a few days, the base no longer turned on, and no longer recognized the peripherals, only the v3-way pedal recognized, because it is always connected separately ........

    the fifth photo, when I made the first installation, this pop up window kept coming out, the drive was updated, disappeared for 2 seconds, reappeared, updated and disappeared ....... this until I closed it by clicking on the x

    practically I'm a basket case ...... I hope to solve the problem as soon as possible ......... I haven't been able to play yet ........

    I hope I have been clearer in the explanation of the problem

    Thank you

  • What does it do without the wheel connected?

    I am from the same wave (last Thursday 11/11 I got my CSL DD) with similar issues. It is the wheel and base not making proper contact. I McGyvered a solution that has made the problems go away. See the added PDF with my situation and solution with a makeshift spacer. I installed it last Sunday and it is working perfect ever since. If it is happening to more wheels, perhaps the QR1 on the base side is too deep, preventing the pins from making proper contact and making a mess of everything.

    Without proper contact I had at least the following list of issues

    • Wheel not showing up in the driver
    • Attaching wheel makes both wheel and base disappear from the driver. Powercycle the base to get it back.
    • Sometimes it would stop showing the base as well with the wheel attached
    • Buttons not responding or only responding once if you press them while the base makes a little contact when turning the wheel.
    • Wheel constantly wanting to reinstall firmware it already has, but saying it has none installed
    • Ingame: “Caution: update firmware” or similar on the wheel screen

  • So the pins on wheel were not reaching inside the female slots of the base???

  • Well, my solution lasted about a week before the troubles returned. Wheel cuts out when used at an angle while driving over kerbs. Best tested in the last corner of Austria in F1-2020 or hit the inside kerb on the harpin at T3. You'll lose the wheel for 10-20 seconds (so no upshifting) before it comes back. Have contacted Fanatec support for RMA.

  • I'm in the same boat. 2 nights ago I started losing the wheel randomly. I've since ended up in a mess of firmware updates and weird wheel behavior. I've initiated a service request, but now I'm stuck without the new wheelbase I waited 6 months to get. Makes me fee ill.

  • Hi. I had similar problem. Fix below.

    Unscrew screw in black locking clamp, then push wheel base hub and tighten locking clamp again.

    Unfortunately wheel base hub is ended with usb-c plug and it seems that it's sliding out of its socket. I think locking clamp is too weak to ensure stable mount. Fanatec should find other solution to prevent this problem.

Sign In or Register to comment.