CSL DD - USB Device not Recognised

I have an issue with my CSL DD on PC. It has been working fine for 2 months but today when I plugged it in, it does not recognise the device, and gives me the error "USB device not recognised"

I have tried different USB ports, uninstalling the driver, installing the previous driver. (423), as well as trying other computers. I also reset the settings on the device.

I suspect the Latest Firmware update is the issue. (429)

I tried logging a support call but when I get past the my products page and select the CSL DD and click on proceed it takes me to a sales FAQ.

I have posted a sales support form. Is fanatec support always this bad? No phone numbers or email addresses?

Comments

  • God Morning,

    the only Number I've found is the official Endor AG Number.

    This is a German Phonenumber +49 (871) 9221-122

    You can give it a try.

  • This Phonenumber stays in a RMA E-Mail

    +49 871 9221 299

  • David ChiengDavid Chieng Member
    edited November 21

    from your product page in your account, you can select the item and send support a message. there will be a few troubleshoot questions for you to answer and they will reply in a day or two.


    when you updated to 429. did you delete the 423 software and folder, fr your pc, before downloading the 429 and installing it.


  • not working. as stated it directs to sales faq. which is about as much use as a chocolate teapot

  • My CSL DD is not getting detected, and it wants me to push a connect button wich doesnt exsist

  • Resolved the issue myself. Turns out it was a faulty USB-C cable. Fanatec are sending me a replacement. I do think that connector is a design fault and is potentially too fragile.

Sign In or Register to comment.