CSL DD Forcibly Rotates to Full Lock

I am having an issue in Ac and ACC where the wheel decided to rotate to full lock on its own whilst driving this can be after a few seconds or many laps. Steering input is still seen as correct in game, the wheel just wants to turn on its own to the full lock and be held in that position.

This can happen gently or with some force.

After leaving AC, the wheel stays held in this position, in ACC it blocks the game from closing until the wheel is turned off.

Looking in the driver control panel, I could see the wheel at -1080 and when turned the degrees are shown correctly.

I am using Driver 429, I did try 432 beta and the firmware from that driver, but the issue happened as soon as leaving the pits so reverted to 429 driver but still the later firmware as I am very nervous about rolling that back. The problem was occurring before I tried the beta driver anyway.

After closing the game, restarting Fanalab and switching the wheel off and on again returns things back to normal.

I am wondering if anyone else has experienced this fault, and if there is a solution?

Are there some logs that are worth posting?

Comments

  • Tim KocksTim Kocks Member
    edited December 2021

    I've had an issue with my previous CSW 2.5 where after a few corners or right after leaving the pits, it would go full left and violently shake on the end of rotation (different end of travel than CSL DD) (also AC/ACC and more)

    What fixed it for me after many driver and firmware versions tested, was just trying all USB ports till one worked flawlessly. Took me 2 weeks of frustration, but never had any issues afterwards.

    Don't know if it helps, but it's worth a shot.


    If you're on PC, and have a second monitor, open the driver page whilst driving. If the wheel or base seems to disconnect if you have the issue, it might be that the C clamp on the shaft isn't bolted down tight enough.

    I had this issue on my CSL DD, though the behavior with this issue was different to your description.

  • Thanks for the reply, I am now thinking its a USB issue rather the anything to do with the wheelbase, its been behaving itself for the last couple of days after some unplugging and plugging back in.

Sign In or Register to comment.