SOLVED - SQV1.5 Not Recognised in Driver 429

edited December 2021 in Fanatec Other

I recently purchased the ClubSport SqV1.5 and am experiencing several issues that are preventing me from using it.

The shifter is connected to my computer via the official USB adapter (My rig consists of ClubSport V3 pedals and a Simagic Alpha Mini + Wheel).

When I first plugged in the shifter, the Fanatec Control Software recognised it, I updated the firmware and I was able to calibrate it no problem. I then loaded up AMS 2 but was unable to assign any gears in game.

Searching for solutions, I realised that my drivers were out of date (v3XX – I can’t exactly remember). I installed the latest v429 driver but when that was installed, the shifter was no longer recognised by the Fanatec Software.

I have tried reinstalling the drivers and using different USB ports. Windows recognises the device but not the Fanatec software.

Also, when I try the V3 pedal “Rumble tests” in the new Fanatec 429 software, it crashes, so guessing this is still a WiP?

Anyone out able to offer a solution? Currently the Shifter is just an expensive bit of Objet d’Art. (also if anyone has any further tips for making AMS 2 see the device, that would be great).

Many thanks.


  • edited December 2021

    The ClubSport USB Adapter is not yet implemented into the new UI - you have to use the old UI for now until its coming in one of the next driver versions soon.

    The rumble crashes for USB Pedals was a known issue of driver 429 - update to the latest driver 433 and thats at least already fixed. Or also wait for the next official driver 434 coming soon which then would fiix both of your issues at once.

  • Brilliant, thank you, what's the last version I need to to install?

  • As edited into my last answer that would be 433 at the moment (RC status) and soon 434.

  • Sorry, I need to install an older version to make the USB adapter work, which one would you suggest?

  • nono, the USB Adapter still works with driver 429 and also 433 - just not in the new UI but the old UI is still working fine (accessable via regular Windows Gamecontroller Menu).

  • Gotcha, understood and have managed to recalibrate the shifter. (didn't realise before the desktop shortcut was accessing the windows menu to calibrate my pedals)

    Thanks very much for your help. Unfortunately I still can't get AMS2 to recognise the shifter but I'll do some more searching for that.

  • I have the 1.5 Shifter and the CSL DD, same problem! Nothing detected other than SQ mode. Calibrating left 2nd and 4th being registered as 2nd and 6th as 4th but nothing detected in games.

  • For my CSL DD all my rims were stuck in calibration mode when the shifter was in H-patter mode, with no way to calibrate the shifter's H-pattern mode through the driver or wheel.

    For me the following worked for the CSL DD:

    • used the short cable to calibrate (longer cable can have issues -only during/pre-calibration- according to Fanatec)
    • unmount the wheelbase from rig/stand (holding it between my legs) (calibration issues can be caused by rig/stand not being properly grounded)

    I did both at the same time to avoid have to undo and redo my cable routing, so don't know if either one of the solutions or the combination of both solved it for me.

  • Really? I have same problem, in H mode, csl dd can’t detect anunsignal from shifter.

    1 month ago I send both to fanatec warranty and they fixed with new rj12 with ferrit-core. (In h mode my pc detecta wrong signals)

    But with the new driver, the problem come back. Only works with seq mode. In H mode there is no signal, its impossible to calibrate. I check with rj12 ferrita and with rj12 large and short from shifter or clubsport v3, and nothing works.

    Even I tried to come back older drivers but same problem…

    Any idea?

    Thanks for your time and have nice christmas

  • Tim KocksTim Kocks Member
    edited December 2021

    Have you tried with the short cable with the wheelbase dismounted? i.e. holding the CSL DD wheelbase between your legs.

    The forum thread giving me this solution said with every new firmware, you need to redo the calibration process again, as the calibration issue re-emerges.

    I've only done a rim firmware and driver update since I calibrated it and it has kept working so far. (so no wheelbase firmware update yet)

Sign In or Register to comment.