My DD1 is a brick

I've had the DD1 since the first release, and it has been fine. Last week I bought and installed the Podium Porsche Wheel with the Podium Button Module Endurance, and the latest driver (352), and Fanalabs. Except for some ITM display issues things were fine. Today, while running iRacing, the Podium Button Module Endurance display froze in S1, and the entire unit was froze, that is not recognized by my PC nor iRacing. After removing power to the DD1, I tried several times to restart Win 10, repair the driver, re-install the driver, remove the driver and install an older version, changed the USB connector for the DD1, Nothing worked, the unit powers on, but Win 10 does not recognize the hardware.

Please, some advise.



  • Contact support via the website.

  • Thanks, James. Sent a request last night. I hope it is a quick process.

  • Note that today is a holiday, tomorrow a bridge day, then weekend so dont expect an answer before next week...

  • 20 May -

    I did receive an email from Fanatec Support with a procedure to try to restore my wheel base to operation. The process did not change the situation, but I am glad to know that the support team is taking action to assist.

  • New issue.

    Support is trying to help me and my DD1 is on the way back to repair service.

    I bought a CSL Elite to use in the meantime, because I had committed to some team races in my league. I have the ClubSport Steering Wheel Formula to go with it.

    But the drivers or the base thinks I have a separate shifter, and will not recognize my wheel's paddle shifts. It indicates that I need to calibrate the shifter in the setup/tuning menu. The paddles light up in the config window, (ad the h-pattern flickers) but have a conflict when I try to calibrate in iRacing.

    Thanks for any info or ideas.

Sign In or Register to comment.