Steering Wheel not detected/disconnecting

Anyone have issues with a wheel not being detected by the PC? mine has maybe 5-6 hours of use and it started to randomly disconnect while driving, then it would not connect at all. The steering angle still worked and the pedals worked fine but none of the buttons/lights/display/shift paddles would work on the wheel. I was able to loosen and retighten the screws around the pins of the wheel and get it to be detected but any slight pull on the wheel, even just pulling the shift paddles, cause it to disconnect. I do have a support ticket into Fanatec but wondering if anyone knows of a fix?

Wheel base is a CSL DD and wheel is the Formula V2.5X. Just wanted to see if there was anything I could do quickly to get it working as it is the only wheel I have. All of the drivers and the Fanatec Control Panel are updated.


  • Update for anyone interested. I was told about the possibility of the main shaft not being seated completely in the wheel base. I loosened up the clamp and pushed the main shaft in slightly until it was fully seated. Problem seems to have been fixed. I'm thinking I may have been accidently pulling on the wheel during braking and pulled the main shaft out slightly. Going to loosen up the brake pedal slightly to prevent myself from doing that anymore.

Sign In or Register to comment.