CSL DD WHEEL BASE

I have connected my CSL DD Wheel base to the CSL Elite Pedals and McLaren GT3 Wheel, but my computer does not show the devices in the Device Manager. FantaLab shows the devices. I have updated the drivers and nothing is working. In Fanatec Control Panel shows motion on gas and brake pedal, steering wheel buttons light up when I press them, but can't callibrate the wheel. Not sure what is going on and why my wheel base is not working. Does anyone have any suggestions? Thanks

Comments

  • have the exact same issue


    did you find a solution?

  • Have you tried a different USB plug?

    Make sure you have not set 'USB selective suspend' option to enable. Just so your USB is always on.

  • I am having a similar issue. I have a CSL DD and two fanatec wheels with two universal hubs V2. Everything was fine until last night when I got a pop-up while in a test drive. Everything was out of control. I x'ed out of iRacing and proceeded to update my 429 drivers to 434. Nothing has worked since. I've tried several USB ports. I have tried to reflash the firmware. My PC cannot see my wheel base. Is there a way to go back to the 429 driver?

  • Just uninstall 434, reinstall 429 and then reboot.

  • David ChiengDavid Chieng Member
    edited January 8

    @Bruce

    Does that work? Did you flash firmware from 429? Or just using 429 driver with 434 firmware in your base?

  • just using 429 driver 434 firmware

  • i can't get 434 firmware off

  • RaindancerAURaindancerAU Member
    edited January 8

    When you reinstall 429, you need to manually flash the wheelbase and motor firmware in the driver.

    I had to do this with my CSL DD as the 434 firmware would not detect my h shifter - it detected sequential just fine, but switching to h pattern would not get it to recognise during the calibration process.

    My GT DD Pro worked fine, but my CSL DD did not.

  • David ChiengDavid Chieng Member
    edited January 9

    Correct me if I am wrong guys but I think there is a little tick box you need to select at the top of the Fanatec control panel, I think on the top right, in order to manually flash the firmware.

  • That is correct and that is what I needed to do


Sign In or Register to comment.