WRC wheel stopped working

Got a full CSL DD setup a couple of weeks ago with the WRC wheel. Was working great, but the wheel came damaged (D stick wasn’t working). I didn’t mind, because everything else worried great.

Unfortunately, it now appears to have stopped working. The display randomly switches between random characters, and the rev strip changes colour along with it. The light above the Xbox logo button won’t turn on either. All this has resulted in my wheelbase being unable to connect to my Xbox (I assume because the WRC wheel isn’t being recognised).

I went into the app on the laptop, and the force feedback functions seem to be working fine. It’s just the steering wheel that is the issue.

I sent a support ticket a few days ago and have got nothing back. At this point I just want my steering wheel replaced, but if it’s a fixable problem that works too.

I have some pictures of the display acting strange to show as well

Thanks for reading through this, I’d appreciate any help you can think of


Comments

  • These didn’t add to the original discussion for some reason

  • Did you try to manually flash the firmware?

    Do you see your wheel at all when connected to the PC?

  • I didn’t manually flash the firmware, how would one do that?

    Also I did see the wheel while it was plugged into the PC, it recognised it. When I ran tests for the rev strip and the display I got nothing though.

    Both are working now again for some reason, the wheelbase still won’t go into Xbox mode and the light above the Xbox home button still isn’t turning on, so the main issue still hasn’t been resolved.

  • Shot in the dark, but have you removed the wheel from the base? Maybe try that, check that none of the pins look damaged, then reattach it. When you do, seat the wheel on the shaft and give it a FIRM shove to make sure it's fully attached before tightening your QR.

  • I had similar issues with my CSL Elite, my GT DD PRO switches with WRC to XBOX mode without a problem which led me to believe the problem was with the base. Do you have any other wheels? I also have Formula V2.5x which was switching to xbox without a problem.

    So I was attaching it first (after starting the base), switch to xbox mode, then my WRC was able to switch as well until I restart the base again.


    You can try to manually flash the firmware. If you go to firmware manager (button on Fanatec Driver Screen), on the right top corner there is a checkbox to enable manual firmware update, if you check it, it will enable update firmware buttons for all of your peripherals regardless of the status.

  • Yeah I did check that, should’ve mentioned it. No pins damaged.

  • I don’t have any other wheels unfortunately.

    A new development, when I went to flash the firmware, the wheel wasn’t being recognised at all anymore. I took it out and put it back in again, and now nothing is being recognised. Does this mean both the wheel and the wheelbase have problems or just the wheelbase?

  • edited January 8

    Boosted Media has a pretty good video about deleting the old drivers and updating new ones and flashing firmware. All that. I would.check that video out. Might have to remove the drivers and start fresh. https://youtu.be/wvtmZxlaxPU. Might help. Idk a good place to start at least.


    Ps. What cockpit are you using in that picture?

  • There are bunch of executables in the Fanatec folder for updating individual components. If your wheel stuck in the bootloader mode, you should be able to run FwUsbSteeringWhellUpdater.exe and try to flush the firmware again.

Sign In or Register to comment.