CSL DD Wheelbase Loses Connection With PC

Hello everyone,

I've been having some sudden stability issues with my CSL DD wheelbase and I'm posting here because all other methods of contacting support have failed (more on that later).

So anyway, yesterday, while I was actively using my CSL DD in-game, it suddenly lost connection to the PC. When this happened, the Fanatec Firmware Updater software was displayed, and the status light became yellow permanently. The PC, Fanalab, and FanatecControlPanel cannot detect the connected wheelbase when it's in this state, and the unit is unusable.

Sometimes, it will resume normal operation after power-cycling and swapping steering wheels multiple times. However, after about 5-10 minutes of use, it loses connection again, displaying the yellow status light. I run both a ClubSport Universal Hub V2 and a ClubSport Steering Wheel Formula V2, and it makes no difference which one is connected. After a few minutes, the wheelbase loses connection with the PC.

After the initial incident, I upgraded the Fanatec driver to 434, but it did not resolve the issue. The only difference I've noticed is that the status light blinks yellow/blue when the unit loses connection instead of solid yellow.

I've also observed the wheelbase unit will reconnect to the PC if I do not have a steering wheel mounted, but the connection is lost when I connect either of my wheels.

The pictures below are three different message logs that are displayed when the updater automatically pops up after the wheelbase loses connection.

So I tried 10+ times to create a support ticket for this, but I get a "Please enter a message and a subject" error every time. I attempted using 3 different PC web browsers and an iOS device with the same result. Gave the live chat a try last night, and it initially told me in first in line and then failed to connect after a minute or two.


Comments

  • Check this:

    If the hub has popped out, loosen the bolt and push it in.

    After assembling it, make sure that the clamp bolt is very tight.

  • Thanks! Looks like that did the trick.

    There was a pretty obvious gap between the clamp and the hub. I will have to keep an eye on that from now on.

  • Do you unconciously pull on the steering wheel when steering?

    I will pretty close to the steering wheel, with my elbows at right angle when I am holding the wheel. And I will make sure I do not pull on the steering when adjusting my seating position or anything else.

  • David

    Thanks times two-been fighting the same problem for two weeks .

    Didn't get a reply from Fanatac as of yet. Thanks for the help.

    Fixed

    Rick Vaughn

  • I get what you're saying, but this should not be happening through normal use. Unless you're sitting there and actively pulling the wheel towards you like a gorilla, these shafts shouldn't be disconnecting like this. IMO, there are far too many cases of this happening for them all to be user error. It's a design flaw in the CSL DD itself.

    Honestly, I feel like it's probably worthy of a product recall, but I doubt Fanatec have a suitable fix for it. And since this isn't the automobile industry and lives aren't at risk, no one's going to force them to fix it, and they certainly aren't going to issue a voluntary recall themselves.

    They'll hope that most people will fix it on their own, and they'll take care of the ones from people who actually take the time to send it in for repairs while under warranty. But as long as the fundamental design stays the same, this problem isn't going to be "fixed", and people will have to live with it.

    Some time will pass, and eventually there'll be a "CSL DD V2" with a new improved shaft/ locking design and we'll have the opportunity to spend hundreds of dollars to "upgrade" and solve our problems.

  • Wow this did the trick for mine. I was getting weird issues with my CSL universal hub seems like that did it.


  • Totally agree with you there. This is something that has happened far too often and definitely require a design fix. Hopefully QR2 will reflect this.

  • I don't believe this needs a V2 of the wheelbase. The main thing is the plastic collar not being tight enough to prevent the shaft gradually slipping out or getting dragged out when a wheel is removed.


    If they develop a better collar, that is all that is needed.


    I actually have both the CSL DD and GT DD Pro and they both have this issue. My CSL DD has less of an issue than the GT DD Pro as the collar can tighten a lot more than the one on the GT DD Pro.


    In normal use, it is not a big issue, the main thing is that I swap wheels often and the action of removing the wheel can pull the shaft out a bit. I have taken to simply examining the gap on the shaft after I remove a wheel to ensure the shaft has not been pulled out as well.

  • Well, I think regardless of if they want to call it a V2 or what, the current shaft/collar/locking mechanism needs a rethink.

  • Just wanted to say thanks to Hristo for sharing the info on how to fix this. Happened to me a couple nights ago and took about 5 minutes to resolve using these instructions.

  • I have the same problem with 5nm, I fitted the steering wheel the 1st time and never took it off again so I think the problem is different.

  • Thanks so much for your advice, this solved my problem. I think that mine got loose because when I have friends over they tend to hold on to the wheel when entering and leaving the seat, pulling on it. I must remind them not to use the wheel that way.

  • Thank you! Solved the issue for me!

Sign In or Register to comment.