New Shifter Not Calibrating

My new Clubsport Shifter SQ will not calibrate. But what is strange when I'm trying to put into calibration mode I've noticed the pattern was wrong. For example, when I move the shifter to the 1st gear position it displays 3 on the hub display or I when put the shifter into 4th gear position it displays 6 on the hub display. Is any way to correct this? I have unplugged it multiple times, change the rj12 cable twice. I'm at Witts end. Any assistance would be great. Thanks!


  • Do you have a direct drive wheel and is the shifter mounted on a metal rig? If so, dismount it and put it on your leg. Then it should work and you can calibrate the shifter. After that you can mount the shifter again. I had the same thing and it worked for me like this.

  • Thanks Markus, I'll try that tonight. Thanks for the tip!

  • Had the same issue, this worked for me. You would think Fanatec would now have this in their FAQ section

  • Turn your wheel to the left or right stop and it will calibrate while holding the wheel at the stop. Then you don't have to take it off the rig. I don't know whey that works but it does.

  • did this fix the problem? im having the same issue..

  • thanks Markus for the tip, removing my shifter from the rig did allow me to calibrate properly so it would stop occasionally selecting the wrong gear.

    i had this issue from time to time while using a Fanatec usb adapter too, now i have a GT DD with the shifter plugged directly into it and got the same thing... (have a metal/tubular Obutto rig.) i'm assuming it's some kind of EMI/static issue? i noticed the USB C and pedals -> wheel base cables that came with the GT DD have ferrite cores so i figure Fanatec had enough customers encountering this problem that they addressed it that way.

    i might see if i can get a replacement cable from them with the ferrite cores for the shifter and see if that eliminates the problem so it doesn't have to be removed from the rig for calibration.

Sign In or Register to comment.