CSl Elite pedals not recognized


seems i am having same problems as others.

i got my DD pro GT bundle yesterday. i got the load cell brake, i connected it all. i am using the PS5

i turned on and the wheel works but none of the pedals are working.

this is what i did hooking it up.

i moved the original brake into to the clutch port and also tried just disconnecting altogether. i am not using a clutch so don't really care.

i used the RJ12 cable to connect the load cell to the accelerator., form load cell port to the load cell/wheel base port. i also made sure to put the labels on the wire going from the right one to the other, although i am not sure why that would matter

connected the RJ12 cable from the load cell wheel base port to the pedal port in the back of the wheel base.

i believe that i have everything hooked up correctly yet nothing from the pedals. i have restarted my console, unplugged everything and replugged everything.

i feel like i have exhausted all my option.

can someone help???

it also my understanding that everything should work right out of the box and there is no tuning needed, i only have PS5, i am not on PC





    I've bookmarked your thread. hope we hear something soon...


  • Hi Troy,

    me too!

    I also hooked up to my laptop and it did recognized my pedals on there, all 3 when I pressed they registered, so I would have to think that the pedals themselves are working. I downloaded all the latest firmware as well.

    Hooked back up to the PS5 and still nothing. I feel like my RJ12 cable has a good attachment at the back of my wheel base....I have read comments about theirs being a loose connection. I just hope that my pedal port on the back of my wheel base isn't bad and I have to send the whole thing back. But I am not sure how you would even test that?

    And I also tried disconnected my load cell and hooked up the original brake and accelerator. Nothing with that either.

    Very frustrating!

  • Ok, so now our situations are different. I can't get any pedal except the LC brake to register on the program. I get no signal from gas or clutch. Those items not working, also don't work in any game on PS5.

  • Yeah, not exactly the same but very similar.

    I tried GT7, Assetto Corso and F1 2019 and same with all of them....wheel works, pedals don't.

    I said screw it and actually just bought the standard CSL pedals from someone on ebay. I will see if they work when I get them and let you know.

    But I am afraid that my issue may not be the pedals themselves, it might be a connection thing.

  • WARNING.....

    Fanatec wont refund their shit product that doesn't work because THEY took so long to respond.

    this company is shit. do not order anything from them.

  • @James ,

    Is that it then?

    They refuse to work with you because your warranty expired AFTER your support ticket was created but BEFORE they got around to following up with you?

    You have a support ticket and can prove it was opened prior to the expiry of your warranty? Or are you referring to the refund period? 14 days or whatever. Either way, if you can prove you contacted them before the expiry date for either situation.... I'd have zero issue making some very loud noises about this.

    if this is standard practice, they are gonna be sued and cleaned out one day. They already only have a 2 hour window in Europe for speaking to Sales/Tech Support/Customer Service. I am a tech support engineer for an enterprise company, we'd not be in business if we treated our customers this way. They are only getting away with it because they sell to individual consumers, not other Enterprise companies.

    Please follow up if you can with details of what was said and why they refused, and what their justification was. If it's how you describe... might be time for revolution or crusade. They can't treat us that way, especially not in Europe. 100% That described behaviour has to be against some consumer rights laws here.

  • I am having the same issues. This is horrible. Has anything been done to fixe this issue?

  • Did any of this get resolved? Just got ours last night. Everything worked fine except pedals. Not detected on anything. Not even showing up on my device list on PC when coneected using the USB cable into the computer. It’s like they are getting zero power or connection.

Sign In or Register to comment.