podium wheel base CANNOT DETECT any wheels

I have lodged a technical support enquiry but the webpage frozes so I'm just posting here again (will try lodge the support enquiry again later). Here is what I wrote in the enquiry message

I'm having the following problems with my podium wheelbase (ps4 compatible version) 

1) the fan turns to 100% (VERY LOUD) as soon as I turned on the wheelbase.

2) the wheelbase CANNOT recognise the F1 racing wheel that comes with the base. I also have a podium r300 wheel which works fine on my previous csl elite base, but the podium base still DOES NOT detect it when I attached the wheel.  

The attached video (link https://www.youtube.com/watch?v=hwZLse7cpNs&feature=youtu.be ) can show you how much the fan is throttling at. Also, you can see from the video that the LCD of the wheelbase is only showing the pedal and shifter logo on the top right corner, meaning that the wheel was NOT DETECTED by the base. The PC driver and fanalab I have also DID NOT detect the presence of the wheel even though I have attached it to the base.

I have tried to update the driver and firmware to 365 and tried to downgrade to the previous version, but still NO LUCK.

The attached photo shows the pinhole of the base.I found that three wholes DO NOT have the gold metal materials inside and I suspected that it is the reason causing the NO WHEEL DETECTION problem. 

I left the wheelbase in the box since I bought in early April. It is no until recently that i open the box again as my direct drive wheel stand finally arrived last Thursday. Now I probably won't get a new replacement base, but I'm hoping that I can still send it to you (if necessary) for further diagnosis and hopfully get it fixed.


  • Psql .Psql . Member
    edited May 2020

    What are all your versions you currently have? Driver, base, motor and wheel?

    Normally if you hear the fans at 100% your motor firmware is not up to date yet.

    The 3 missing pins is normal. Mine has the same and works without any issues.

  • currently using driver 365, the wheelbase firmware is 672 and the wheel base motor firmware becomes 0 after I updated the wheelbase firmware. If I click the update motot firmware button on the current 365 driver menu, then the window just closes automatically and nothing happens (this happens to all the previous drivers I tried as well).

    when I remove this driver and using other previous versions, the wheelbase motor firmware is 29 i think (if i chose not to update the wheelbase firmware first), but if I click on motor firmware update button first when im using the previous versions, the screen closes and frozes at the game controller screen. the previous drivers that i have tried include 335, 346, 347, 352, 356.

Sign In or Register to comment.