driver 439/DD1 update fail

Hi, DD1 been working no issues until recent 439 driver/firmware update package.

Firmware appears to update successfully, however upon subsequent (automatic) power off/restart, firmware updater says:

"Wireless Quick Release Update Mode

Error: Connect device failed(Error: Initial ping failure: No response received for ping command.).

Power OFF the wheel base and retry update.

If the problem persists, please contact FANATEC support."

I have retried many times, different USB cables, ports, different PC, same result."

I contacted Fanatec support a wwek ago and have had no response.


Can anyone offer suggestions/help? Thx

Comments

  • btw - also tried reverting to drivers 381 and 402 - same result.

  • You need to contact the support. WQR failures cant be fixed by the user.

  • How long have you been using the DD1?

  • been using dd1 1-2 years, no issue until this

  • David ChiengDavid Chieng Member
    edited April 24

    quite ridiciulous if your base is outside the warranty period and you go and update the firmware and in the process, it bricked your base...

    will Fanatec fix it for you without any cost to you?

  • edited April 24

    If his base is 1-2 years old then it's still under warranty as the DD1 has 3 years warranty.

    So yes of course Fanatec will fix it for him without any cost to him.

  • Hi Maurice.

    I have this same issue but I'm out of warranty as 3 years was not available at the time. I have to pay all the costs. RMA is ongoing.

    I'd really like an option to fix this issue myself without having to ship the base. Which circuit board relates to the WQR ping error?


    \Patrick

  • Jim GroveJim Grove Member
    edited April 24

    I had this issue yesterday. It took 30 or 40 minutes to fix but I get the impression it's not a wheelbase issue. More directly, it's related to actual PC usb port power. I've found similar issues with a VR headset showing as disconnected when it's obviously plugged in and worked fine 24 hours before.

    Yesterday, when switching on the wheelbase, the wheel would not rotate/calibrate and I would receive a firmware failed update box on screen with a ping error. I swapped USB slots and eventually unplugged a few other things and finally it all worked. It's a strange issue that happens every few months or so but it seems that not enough power is being delivered to certain slots and that can cause an issue with the DD1 and sometimes other peripherals. A swap around tends to cure everything. Of course, if that's all been tried, the issue will lay elsewhere....

  • it’s still in warranty so should be no issue. frustrating it’s been a week since i put in a support ticket and still nothing from fanatec…

  • Rob, it will take awhile.

    Someone in Germany posted an issue where after 3 weeks they are still waiting for the return shipping label.

  • Just an update for anyone who's interested. After 11 days and still no response from fanatec support I managed to bring the DD1 back to life 😊.

    After being bricked by driver update 439 🙁, I tried 440 (beta), 402, then 381 - all using bootloader mode as unit was non-responsive and not recognized by PC. All gave the same result. Tried different USB ports, cables and eventually different PC - again, same result. Given the ongoing lack of love shown by fanatec support (🤬 which many seem to be experiencing) I decided to try yet older firmware drivers. Hit the jackpot with driver 336. Even though DD1 is now running significantly older firmware than previously, at least it's working!! Definitely a case of persistence & luck over skill here.

    I'd love to try to update firmware again, but I'm too scared now and think I'll just live with 336 until fanatec can give me some assurance update will work.

  • Congrats Rob on getting it working. I bet it's a big relief.

    I've also tried 336 which gets the base back working but still the wheel is not recognised.

    What motor firmware are you running?

    When you installed the base firmware did you get the red symbol through the wheel when you open the app?


  • .

    the red Symbol means no Wheel is detected, maybe because the driver and Firmware dont know the wheel if it's a newer wheel than the Base Firmware which the Firmware dont know.

    Otherwise it's an issue with the WQR and WQR issues can only be fixed by the support.

  • edited April 30


    Hi Maurice.


    I have the WQR ping issue.


    I have RMA ticket in progress but since the issue was caused by failed firmware update I'm still holding out hope of finding a s/w fix.


    \Patrick

  • Rob NessRob Ness Member

    Hey Patrick, I’m now running pc driver 336, wheel base firmware 656 and motor firmware 30. i didn’t have the red symbol when i updated using 336. good luck to you - I know how super frustrating this stuff can be. question to you: after getting the wheelbase back to life using 336 have you tried updating to 439 again yet? could be worth a try if your stuck with wheel not recognized. which wheel do you have? mine is clubsport formula.

  • Thanks Rob.

    Yes after installing 336 driver and firmware I tried upgraded to 439 driver but wheel still not recognised. WQR showing as 0. Wheel is McLaren GT3 v1. I'll try downgrade the wheel firmware. I can get access to a clubsport formula so I will try that aswell.

  • Rob NessRob Ness Member

    and a final note… updated firmware to 439 and all went okay, DD1 back to life and fully up to date: pc driver 439; wheel base 691; motor 42; WQR 6. I feel very lucky.

    what a horrible experience - shame on fanatec customer support. I will say fanatec tech support did reach out to me on day 11 asking me to RMA the DD1 - glad I can now avoid that.

    Best of luck to any and all in a similar position.

  • Great result for you Rob. Thanks for reporting back here with this info. Hopefully it can help a few people sort their DD1/dd2 issues themselves and avoid long downtime.

  • Think about the same happening with your phone bricking after firmware update. I would be super pissed and disappointed by the company if it would not honor a repair after this.

Sign In or Register to comment.