DD1 Driver & Calibration issue + FanaLab Tuning Menu w/ R300/button cluster pack

Hi all,

I purchased my Fanatec DD1, Podium Hub, R300 wheel w/ Advanced Paddle Module, ClubSport Button Cluster pack & ClubSport Inverted Pedals earlier in April. I did not purchase a standalone handbrake or H-pattern/sequential shifter. My sim chassis finally showed up late last week so I was unboxing and assembling the rig all weekend.

I have encountered a series of issues during my attempts to install and calibrate the DD1, pedals, etc:

  • The communications cable from the pedals is plugged into the back of the DD1, the DD1's USB to the PC. I have tried several USB ports on the PC, all of them SS-USB.
  • I have tried drivers 335, 346, 347, and 352 available on the DD1 - no driver installed has allowed me to access the Game Controller 'Properties' menu in Windows. I get a message 'Please reconnect device and try again.' If all Drivers are uninstalled, I am able to access a seemingly worthless Properties menu that does not map the axes of the wheel or pedals.
  • As recommended, I put the DD1 into Bootloader mode and performed a Flash Firmware, updating to (I believe) 669. This caused 'CAL' to be flashing, and the wheel is waiting for me to calibrate center. I do not have a wheel/button combination with a Tuning Menu button or Funkyswitch (R300, clubsport button cluster) and have read that FanaLab is required to access this Tuning Menu.
  • FanaLab 1.12 and 1.23 (driver-dependent) have been installed and will recognize the DD1, Podium hub and Clubsport pedals - it does not recognize the Advanced Paddle Module or Clubsport Button Cluster pack, I am not sure if this is something that is normally recognized by FanaLab. I am able to access the TuningMenu in FanaLab, but there is nowhere in FanaLab's menus that has a wheel center-recalibration prompt.
  • I later read elsewhere that the Game Controller driver's Properties menu is where you recalibrate the DD1's center without the Tuning Menu wheel button and Funkyswitch. Again - I get the error message mentioned above when attempting to access this Properties menu.
  • None of the ClubSport Button Cluster buttons or paddles from the Advanced Paddle Module are mappable in Assetto Corsa. The Pedals at any stage during this process have not been mappable or recognized either. Prior to installing ANY drivers or firmware, ONLY the Wheel's 900deg rotation was recognized by Assetto Corsa. I am only using Assetto Corsa as it was the game I was attempting to test with.
  • Last, maybe unrelated - I was trying to see if a button combination would access the Tuning Menu in the DD1, and noticed that hitting all 6 of the ClubSport Button Cluster's buttons would change the 'Fanatec DD1' to 'Fanatec ClubSport 2.5' in both the FanaLab's recognized devices, and the Game Controllers control panel menu. I'm not sure what that's about.

My current major issue, as it seems to me, is being able to access the Properties menu in the Game Controller screen, in FanaLab, or otherwise being able to center-calibrate the DD1. I anticipate further issues as it still seems that the pedals/shift paddles/buttons are not mappable in Assetto Corsa, but I'm crossing that bridge when I come to it.

I have searched Reddit and these forums looking for a similar issue, and I've seen similar ones but not the same. I spent about 6 hours yesterday troubleshooting this with all sorts of driver/fanalab combinations and based on thing's I've read here and on Reddit. I've checked all my connections several times and done the typical restart, reboot (including restarting the wheelbase in the Bootloader menu). I'm out of ideas and feel pretty silly having spent so much on this setup only to be this lost with how to get it all working properly.


  • Psql .Psql . Member

    For Podium hub use as a minimum the v346 driver. This also has buttons in the driver to do the center calibrations. For what I know currently Fanalab is not able to calibrate center. It’s only used to make tuning menu profiles and makes it possible to switch between the profiles and tuning menu 1 till 5 that you created.

    Fanalab only recognizes the main components. Doesn’t do/show anything about shifters or buttons. (BME is the exception)

    I would suggest to first stay with driver v346 + Fanalab v1.12 and update all components with the firmwares in this driver. Don’t forget to downgrade if you had newer firmwares. This driver should give you a working setup. Don’t mix drivers and firmware this will result in not properly functioning setup.

    Comp v2.5 mode is there for older games or some newer like Forza 7 or FH4. They don’t work in normal PC mode.

  • Matt DavisMatt Davis Member
    edited June 2020

    Thank you, I will try those combinations after uninstalling everything. I'm confident there is a fix, but I believe I've tried this permutation before. I may not have entered Bootloader with the DD1 with this combination, so maybe if that is going to determine which Firmware is loaded, I'll have some luck. Alternatively, if somebody can provide a .hex file to manually load the correct firmware (or, if I can have several to attempt other permutations), that may be helpful.

    It makes sense that FanaLab's Tuning Menu is not meant to re-center, but that is what all the .pdf files on Fanatec point to for center calibration. Frustrating! Even finding FanaLab was through a search and a few clicks - I didn't know it existed otherwise.

    Thanks! Please keep any helpful tips or relevant experience coming.

  • The DD has a compatibility mode, making it appear as a ClubSport 2.5. That might explain the one point.

    Also, when changing drivers. Are you updating the driver and all firmware together at the same time?

    Have you tried multiple USB ports? USB2.0 on the back of the case specifically?

  • Psql .Psql . Member

    I don’t know if it will help but maybe it’s worth a try to first remove the wheel and try to see if you can update the base and motor without the wheel.

  • Matt DavisMatt Davis Member
    edited June 2020

    I have not tried changing to those specific drivers and then doing firmware; trying that in a few minutes.

    I updated my original post to add some clarity - I've tried multiple ports, are all superspeed USB 2.0 or higher.

    I will try - both the wheel and pedals are recognized by the DD1 on the OLED screen. CAL flashes, regardless, and depending on which driver is installed, the DD1's fan may be on full blast or not (I am under the impression this is a characteristic of being in Bootloader and/or needing a calibration).


  • Matt DavisMatt Davis Member
    edited June 2020

    I was able to fix the issues - for anyone who is having a similar issue with accessing the Driver Properties menu, here was my process that seemed to work:

    • Uninstall all existing drivers and FanaLab
    • Install FanaLab 1.12 and Driver v346
    • Restart PC as prompted
    • Access Bootloader on DD1 by holding power button for 8 seconds with DD1 powered off. Prompt 'Flash Firmware' on bootloader menu. Close bootloader when complete. In retrospect, this may have been a misstep.
    • At this point, I was still not able to access the Properties menu; 'Please reconnect device and try again.'
    • I went into Devices & Printers, removed 'Fanatec DD1' from Windows; then unplugged the USB from the back of the DD1 and plugged it back in.
    • I was now able to access the Properties menu. An 'Initializing...' screen came up. For several minutes, nothing would load from attempting to access the Properties menu further. After several minutes, double-clicking opened the Fanatec Podium properties screen.
    • I was prompted to update the Firmware from the Driver twice; once with a prompt "this Driver includes updated Firmware, update?," and a second time with "this Firmware is not the newest available, update?"
    • After installing both Firmware prompts, I was able to center-calibrate, and verify the button, pedals and paddles were all working properly.

    Thanks for your help, I doubt I would have come across this solution myself.

  • Current versions are:

    • PC Driver 346
    • Wheel Base Firmware 662
    • Wheel Base Motor Firmware 30
    • Steering Wheel Firmware 2

  • This solution does not make sense if you drive AC plus ACC, rF2, F1 2020, etc. We can't re-install different versions of drivers depending on the game.

    AC is not detecting the paddle modules on the Podium DD1 R300 Wheel in either PC or Compatibility mode. I would like Support to look at this.

  • Hey - not sure if you're having the same issue I was, but once I followed the above methods I had no further issues between iRacing, AC, ACC, Dirt 2.0, etc. Has been running fine the last ~3.5mo.

    Only issue I've come into is that occasionally the DD1 will freeze about 30% of the time if I have the torque key inserted on startup.

    Best of luck!

Sign In or Register to comment.