McLaren v2 display and funky switch stop working

edited May 2 in Steering Wheels

I got a DD Pro 8nm and McLaren v2 wheel a.few days ago and have a weird problem. When I fire up GT7 all is well and then suddenly (usually mid way through my 1st race, but sometimes the 2nd) the display will go blank, then tuning menu button stops working as.does the funky switch. If I turn the wheelbase on and on it will be ok for a few laps and then go again. The other buttons appear.to still work. I have checked my ps5 settings and there is no power saving on the USB ports and I tried setting controllers to not disconnect. Does the same thing in PS5 and compatibility mode. Wheelbase, rim and pedals all on latest firmware. Happens with QR lite and Clubsport QR. Has anyone else had this problem or got any ideas what is going on?

Comments

  • Have you checked the clamp on the aluminium shaft of the base and that it is totally seated correctly?

    Do a search for it as there should be a thread sonewhere. Very common issue.

  • Hi. Thanks for the reply. I had read those posts about the shaft and was debating checking it, however, I think I have resolved it (fingers crossed).

    I suspected it was an issue with the wheel losing partial connection to the base so I took the QR off to check everything and found that an extra washer was under the QR meaning it wasn't seated perfectly on the wheel. When the wheel was then in user and under load, it must have been breaking the connection, which would explain why it happened in the first race or two. Just tested it for 90 mins and touch-wood it was fine so hopefully, that was all it was.

    TLDR: User error

  • Ok looks like I spoke too soon - the display still is cutting out again after heavy impacts etc. Removing the wheel/restarting base resolves it. I think the shaft/clamp looks like it is seated correctly but will check again later. I have messaged support so will see what they say when they get back to me.

  • edited May 7

    Just updating this to keep a track of the extra troubleshooting I have done in case it helps anyone else in the future (and also to remind me whenever support gets round to my ticket)

    I have now tried different USB ports on PS5, and a different USB cable with no change. Also when the display stopped working again I unplugged the USB cable from the PS5, then put the base in PC mode, connected it to my laptop, and ran the OLED test in the Fanatec Control Panel software. The display remained blank (also pressing the tuning button on the wheel or rotary for analogue paddle function select fails to display) Once I had turned the base off and on or removed and reattached the wheel, the wheel initializes and the display works again and will also pass the OLED test. The display then fails again shortly after starting any racing and just seems to occur randomly from what I can see so far. The funky switch appears to work ok (as do all others) and doesn't fail at the same time so that just might have been an isolated incident (touch wood). FFB is also fine.

    At this point, I am suspecting some sort of electrical short may be going with the OLED which is causing it to fail in use. We shall see..... 😎

  • Display cutting out and buttons being unresponsive sounds very typical of what happens when the shaft becomes loose and needs to be reseated and retightened. A quick search through the forums should uncover what you need to do.

  • Hi. I have tried loosening the clamp, removing the shaft and reseating it but the problem remains (I think it was seated ok anyway but worth a try). The funky switch is ok now and all the buttons and ffb are fine, it is just the OLED display that stops working (unfortunately I cannot rename this thread to remove reference to that). Cheers

  • I had a reply from support yesterday who asked me to uninstall/reinstall drivers (not really sure how that's relevant as I am using it on Playstation) and to reflash the firmware. I did all that and the fault still remains (I also tried driver 440 with updated firmware for the wheelbase but still no change). I am now awaiting support's response to that not having solved the problem.

  • Ok, I was able to test my setup with a friend's McLaren rim, both last night and tonight, and it ran faultlessly for hours. So my rim definitely has a hardware issue. I have asked support to issue an RMA.

  • Support have said they need to get the wheel in for repair, so awaiting labels to return it now.

Sign In or Register to comment.