CSL gas pedal not responding

Only had my set-up for 3-4 works and worked fine until now - the gas pedal isn't responding at all. I've disconnected & reconnected all the connections, double/triple checked the software (uninstalled and reinstalled the firmware) but still no response. I've logged a fault with Fanatec over a week ago but no response. No idea what I can do to sort it - just know I've paid £700 for this set-up and find the technical support pretty useless and basically have no way of knowing how to solve the issue. Any suggestions ? Many thanks.

Comments

  • edited June 13

    No suggestions, if it doesn't work at all, you have to wait for Fanatec's reply. They will respond, fear not, and replace the defective product. You just have to wait, and that's the hard part. No we would buy expensive equipment if we weren't addicted to simracing. Patience is not our best trait. It is a trait of their customers that Fanatec does not understand.

  • Many thanks Alessandro - it's not actually mine, it's my 15 year old son, so as you can imagine he's not very good at being patient, although I still wouldn't expect a product that cost so much money to suffer from what seems to be a common fault - I've seen so many other people commenting on the same issue. Really appreciate you coming back to me - hopefully they'll respond soon!!!

  • It's been nearly 2 weeks since I logged a ticket due to my son's CSL pedals (gas pedal) no longer working, despite only having had the product for 1 month. How can a company sell such expensive products that simply stop working, but have no way of contacting them or when you try, they simply don't respond. I've essentially spend nearly £800 on a product that doesn't work - can anyone advise of any ways to get in touch with them to find out what they intend to do to fix the issue / replace the products that are faulty. Feel totally stuck / helpless ...

  • I am sorry to hear that Steve. I received all my equipment yesterday (6/29/22). I followed every instruction vigilantly( I was extremely excited and babied the entire process, lol). I read everything very slowly and precisely. My wife laughed at me. Anyways, in the control panel the clutch and load cell worked but not the throttle. I then loaded my a game on my PS5 and Xbox Series X, but no throttle. I have my crew coming this Saturday to do some racing, but now I think that plan will not come to fruition. I put my ticket in last night. Fanatec sent an email that they received my request and so I hope they respond today!

Sign In or Register to comment.