CSL Throttle and Clutch no responding

Today I received my load cell for the csl pedals, but when I connect the load cell via usb to the pc, the accelerator and the clutch don't work, in the fanatec control panel only the brake bar goes up, that of the others two pedals stays at 0%

Anyone else with this problem?


  • It seems like a widespread problem. There are many posts on Reddit, as well as here.

    Different solutions that other users have found by reading on Reddit.

    - RMA and replacement of the basic 2-pedal set, no Csl LC. Replacing CSL LC never works. Fanatec should be aware of the problem.

    - Grounding of the pedals.

    - Different organization of cables on the rig.

    I hope I've given you a lead to investigate.

  • Adrian ChaconAdrian Chacon Member
    edited June 2022

    I read a lot of threads of people with similar problems and it seems that the electronic control of the load cell is what causes the problems, many of them have changed the LC and it has worked correctly.

    On the other hand, I have tried the pedals on the ground and the error is the same

  • CSL pedals are made of stainless steel, with no paint layers, so electrical grounding is very simple. It was worth a try, even if it didn't work. The problem is known, Fanatec will solve it for sure.

  • Ben GBen G Member

    I am also having this problem. First time buying from Fanatec and I am admittedly a little disappointed that they sold this whilst knowing there was an issue with this setup. I'm experiencing exactly what you describe.

  • Bonjour, moi aussi j'ai le même problème avec mon pédalier CSL LC 2021. Suite à l'achat de matériel FANATEC neuf, après quelque heure de gaming, mon accélérateur osciller de plus en plus.

    A présent sur le FANATEC panel control la valeur affiche 0 % même en pressant sur la pédale rien ne s'affiche. Mon load cell fonctionne correctement ainsi que ma pédale d'embrayage.

Sign In or Register to comment.