Please PLEASE someone help me (Podium Hub)

edited June 2022 in Steering Wheels

I am so very upset with Fantec and the product line - Podium Hub.

I ordered the NASCAR wheel with the Podium Hub w/ QR1. The hub isn't recognized. Contact support, wait for responses and go back and forth and complete every process they ask me, like firmware changes, taking of release hub at the wheel base and checking wire harness, taking apart Podium Hub and checking the wiring harness in there, changing to different driver versions.... Nothing worked.

So after weeks of this, they agreed to RMA and sent out another one once I shipped the defective one back.

Just recieved the new Podium Hub and got it all connected and the EXACT SAME ISSUE.

Please note, I can connect the Formula V2.5 wheel in at anytime and it's recognized With zero issue. Never a single problem with the V2.5, so it's not the wheel base.

So now I've spent $3,000 dollars and waited weeks to get a product that still doesn't work. I know I can use my V2.5 in the meantime, but that is far from the point. A lot of money has been spent by me, and a lot of other people, who have very similar issues and similar slow response from Fantec.

So now I have to wait yet another weekend and HOPE they email me back on Monday, probably more "basic troubleshooting" instead of recognizing the issue.

Is there another alternative to being able to race the NASCAR oval wheel, besides the Podium Hub? What do I do? How is this right to keep getting defective products? I'm so damn upset!

I'm looking for help or advice on what I should do next, because this is such bad business practice.


  • I have the same problem with the DD2 und Podium Hub . The first podium hub is sent back and the second makes the same mistake and is not recognized. Formula V2.5 works perfectly. I phoned, in Germany, with the support. And they were very friendly and helpful. The exchange went very quickly. I try to call the support again on Monday. But I think this is a problem with the drivers and firmware. We will probably have to be a little patient.

    Sorry my english is not so good. So i use a translator. :)

    But I understand their disappointment.

  • edited June 2022

    They have stated they suspect it could be a driver issue, but they didn't know for sure. Nice to hear I'm not alone. Thanks for your comment

  • Hi.

    I am also glad not to be alone with the problem. :)

    Do you have a Podium DD2 and is it new?

    I'm trying to call support on Monday. Let's see if they have more information.

    Then I write an comment.

  • Yes, Podium DD2. I planned on calling them tomorrow too. Let's report back tomorrow and compare notes

  • Hey. So after talking to Adrian over at the Germany location, he said they received my first one I sent back and they found it to be working. Since there is no issue with the V2.5, he doesn't think it's the base, but they think they have determined it's the hub on the wheel base. So they are sending another hub for the wheel base.

  • Hi.

    After talking to the support, I should remove the Quick Release Hub and check the plugs. However, this did not help.

    Then again a downgrade to the driver version 381. Also nothing. I will probably have to send the Wheel Base back.

    But the Formula steering wheel works 100%.

    In the Beta Driver Blog, there is a third case.

    The support says this is a rare case. Have already tried so much. It's not funny anymore.

    And even worse now I have to use my old steering wheel when I send it back.

    I hope that the new Quick Release Hub is the solution for you.

  • Hi Siegfried,

    Tha's me, the 3rd case in that forum topic as far as I could tell, but I see there are more like us.. I was roaming around the internet looking for possible solutions and encountered your post.

    I have just received my DD2 last week, so it's a new one indeed. And my Podium R300 wheel got in today, all brand new from Fanatec. Not working whatsoever. I bought it as replacement of my WRC wheel, which was working perfectly, except only low torque mode, therefore the replacement.. Also my v2.5x formula wheel works like a charm. I openend a ticket as well, but I get a little frightened this may take a while.. Not sure if I'm gonna keep it then, looking at the issues with the Podium hub I encounter online..

  • H RekerH Reker Member
    edited June 2022

    FYI, I just ordered a new Podium hub to try with my wheel. I'm hoping it's bad luck and my Podium hub is broken.

    I do it this way, because I'm still in my 2 week return period after buying the DD2 a week ago. If this will not solve the issue, the whole shebang (base, wheel, everything) goes back to Fanatec and I will be switching to the other well known brand.. On top of this issue I also experienced weird FFB glitches in Dirt Rally 2 multiple times, which I never had before. It seems things are not ok with my current setup.

    I was hoping I would not encounter this kind of issuess. I came from a CSL DD as my first wheel ever, no issues at all, worked like a charm. Within a week with a DD2 and things go wrong.

    Edit: I don't want to only complain about Fanatec.. Apart from the current issue I'm really pleased with the DD2. A massive upgrade from the CSL DD (8nm), a far more enjoyable driving experience with that amount of power. So I really hope I will have a working wheel with the new Podium Hub!

  • Hi.

    I sent my podium hub back and also received a new one. Everything went very fast. But the new is also not recognized. After consulting with the support, I was told that the First Hub was not broken. So the DD2 seems to be the problem. I also have a Universal Hub V2, this didn't work properly either. Sometimes it didn't work. Had to turn it on and off several times. Until it didn't work anymore at the end. But I already have the replacement for that. The first hub was broken. But I will not test that on the DD2 not that it breaks. So the exchange products were there quickly. Without any problems. And the support is also very helpful.

    Now only the DD2 needs to be replaced. Hope that there are no more problems.

    Do they also come from Germany?

  • H RekerH Reker Member
    edited June 2022

    Hi Siegfried,

    Did I read correcly that you have the same type of issue with the Universal hub?? I was thinking about buying that one as alternative, but if that's also not working...?

  • Hi.

    Similar. When it was detected, it ran perfectly. But I had to turn the DD2 on and off 2 - 3 times before it was detected. Later it didn't work at all and sent it back. The support told me it was broken. I have the replacement device here. But the support says I shouldn't test it and send the DD2 back.

    Be careful. I assume that the DD2 is broken.

  • Thanks for the update Siegfried.

    Today I received my second Podium Hub. Just tried it, but no, not recognized either, same as you guys.

    I have drawn my conclusions and act accordingly :)

  • Hi.

    I send my DD2 back for repair. Have also tested the Universal Hub. Also not recognized. So the DD2 is broken.

    I hope it won't be long before I get them back.

  • Nice, I hope you have it back asap!

    I have requested the same, I see my DD2 as a DOA, while referring to your cases. I'm in my first 2-weeks and requested a new one as a replacement

  • I'm furious, y'all. This is such horrible practice and obviously this is a global issue. I just got the 3rd attempted repair piece, this time the wheel hub that connects the QR1 to the base. Same exact issue. FURIOUS!!

  • H RekerH Reker Member
    edited July 2022

    Man that's annoying indeed! And now what? DD2 back?

    Now a nr 4 use case arised I just saw, not good, really a weird issue. But I'm assuming most Podium hubs still work right? Otherwise we would have heard more about it I think..

    To me the more reason now to return my stuff to prevent tedious RMA processes.

  • Any updates or progress on your end guys? I'm requested to do the exact same things as you, opening up the stuff to see if all is connected properly etc.. They don't seem to be very willing to replace my DD2.

  • Hi.

    Sent my DD2 to Fanatec. On Monday 04.07.22 arrived at Fanatec and today (07.07) I received an email that I will receive a repaired or a new one tomorrow. Will write a post on Friday. But so far everything went quickly and easily.

    I also have to be fair that I was able to send the DD2 back earlier. It just wasn't clear where the mistake was. And I hoped that the DD2 was not broken. If everything works now, I'm satisfied.

    Will report tomorrow.

  • Good to hear it's now being handled. Did you receive your new DD2 today? :)

  • Hi.

    I received my DD2 on Friday (08.07.22). The Podium Hub and the Universal Hub too. They probably repaired the DD2. The Quick Relase Hub looks new. The Podium Hub and the Universal Hub are the same. Both are now easily recognized. No more errors. The Formula steering wheel too, of course. Tested with Assetto Corso, everything works as it should. Now I am happy again and can go on holiday.

    The repair went really fast and without any problems. The repair took 5 days, here in Germany. With shipping.

    The support was also always available by phone and helpful.

    So if someone has the same error, it's because of DD2.

  • Awesome to hear that, and peace of mind during your holidays :). Enjoy!

  • Same problem here. I've got the DD1. F1 wheel works great. I've got 2 brand new Podium hubs and I can't either one to recognize. Calling support tomorrow.

  • Hi.

    Is a problem of the wheelbase. After repair, it works perfectly.

    Fanatec replaced the Quickrelease hub of the dd2.

  • I'm literally going through this exact same thing right now.

    I have 3 podium hubs that are all faulty.

    I have a DD2 and two DD-CSL and which my other wheels work perfectly on.

    I've tested these hubs on several other fanatec wheel bases and they fail to detect the connected button modules.

    I'm dealing with the Fanatec runaround currently - "send the DD2 back" is a request from their support which is just crazy considering it's not the issue.

    been a fanatec client for 5 years now and spent thousands of dollars.



  • I have got the same issue, cannot connect a brand new podium hub to my DD2. Contacting support, it is very frustrating that they only have phone support for 2 hours a day in German time only!

  • same issue with a brand new Podium F1 DD1 wheelbase and podium hub.

    Works fine with my F1 and RS wheel.

    A Universal hub v2 i also god today, does work, but took at couple of power cycles to get working. The Podium hub does not work whatsoever, messed around with it for hours, changed the QR1 around, disconnected PME, same. Havent had ANY issues with the wheelbase for the two weeks i have owned it after upgrading from DD Pro....until i decided to throw another 1K EUR towards new wheels :(

    Will create a support case.

  • Hello all,

    Today i had exactly the same problem with my DD1 and Podium Hub as discribed above, with a little help of putting contact spray down the little holes of the DD1 hub it worked instantly, i guess dust creeps inside the hub if used without a hub dustcap.

    If you have problems with the wheel itself, it could be a connection that's not neatly seated inside the wheel hub, for a possible sollution look at the picture.

  • I had same issue. Could we solve it by ourselve? which hole it is? Thx in advance.

Sign In or Register to comment.