Wheel refuses to update

I've been trying to troubleshoot this problem for the past 3 days and hoping someone here may have the answer I have desperately been looking for. Happy to give as many details needed, although I am beginning to think I have faulty hardware.

Problem: When I attach my clubsport formula v2 wheel to my podium dd2, It will 99% of the time open the firmware updater and begin updating the wheel. the wheel vibrates through the entire process, and the screen on the dd2 goes blank. the flash firmware process happens repeatedly without any input from me. Eventually it gives an error about getting disconnected. I will add pictures below.


Things I have tried so far:

unplugged everything and re plugging all cables.

I have tried multiple USB ports.

I have uninstalled the fanatec software several times and reinstalled

I have went to the devices and reset the hardware to default manually

I have tried using older versions of the firmware, including some betas

I have tried changing the mode from PC to comp (although I can only try if I am lucky enough to have the steering wheel working) Is there a way to change modes without the wheel attached?


I have managed to get this thing working twice after a reboot, but it seems I can only hope to get lucky enough to use it on any given reboot. It works for about an hour and then crashes and bricks again. Is there maybe some sort of hex file I could use to remedy this wheel? This product was gifted to me and I have only been able to enjoy it for about 1 hour out of over 12 hours of troubleshooting. This forum post is my last cry for help before just buying different hardware. Praying someone here has the answer I am looking for. Thank you in advanced.


current firmware:

Wheel base DD2 - 691

PC driver - 439

Wheel base motor - 42

Wireless QR - 6

Wheel - When I get lucky enough to work, I believe it says 44 on the screen if the wheel

Comments

  • Angel GarciaAngel Garcia Member
    edited August 8

    This screen finishes the update and then immediately prompts the same firmware, while everything becomes inoperable on the hardware.

    Also, while this is happened, the main fanatec software loses connection to the dd2. I assume that us normal when things are actively updating, but it is there nonetheless.

  • Does the error say "Update mode: wireless quick release"? that's what happened to my brand new dd2 after it worked good for one day, I came back to play it the next night and when i turned it on the wheel was not recognized. followed all the troublehooting steps and then after I got this error about a hundred times i made a support ticket and they answered me the next morning, "unfortunately for this you need to send it back to us and we will send you a new one after our technition confirms the defect" they had a shipping label from the warehouse in CA to me a few hours later and now they have it since wednesday and i have not heard anything from them. Needless to say I'm pretty unhappy now after spending $3200 on new gear, made in china is crap i would rather pay twice as much and have a reliable product, also on the my products page the warranty date for my DD2 says 1 year when it was advertised as 5 years i hope its just an error i have a feeling like there is going to more returns with this thing i have no confidence in the reliablity of this thing now. As good as it worked for the day i had it is how bad i'm feeling right now.

  • "also on the my products page the warranty date for my DD2 says 1 year when it was advertised as 5 years i hope its just an error"


    I had a similar issue after I purchased the extended warranty for my CSL DD. It showed only 1 year, when it should have been 2. I was able to get ahold of support through their live chat system, and they were able to correct the issue right away. Granted, this was back in January or February, before their Customer Service became buried by the mountain of support requests that they're still trying to figure out how to dig their way out from underneath. You could try opening a standard support ticket through your My Products page if live chat is unavailable. This will undoubtedly take longer, but since it's not really an "urgent" issue for the time being, that may not matter.

  • It does not say anything about the wireless quick release unfortunately. Just spams the firmware updater for the wheel itself. I had it working yesterday for hours and today its back to doing the same thing :(

  • Angel GarciaAngel Garcia Member
    edited August 9

    Update - I thought I was onto something. Yesterday I turned my pc on and turned the dd2 on with no wheel and just let it sit for about an hour. plugged the wheel in and raced the rest of the day with no problems. Woke up today and the problem is back. Restarted multiple times and still no luck. I happened to notice that the fanatec software is saying its running in 32 bit. I have downloaded the 64 bit several times, so I am confused as to why its running in 32. not sure if that is a part of my problem, but just something ive noticed.

  • wow i feel your pain, what's your warranty status did you try making a support ticket? my new DD2 is arriving saturday but i have no confidence its going to work for very long now, i liked it so much i'm probably going to end up with two of the damn things because one will always be on it way back to fanatec. at least it does not seem like to many others are having these same problems, i posted my story the other day and had over 80 people read it but nobody commented. hopefully its just a one and 10,000 thing and the new one wont break, its going to see alot of use when i get it.

Sign In or Register to comment.