[Resolved] Fanatec Firmware Errors - Windows 10/11

I received my GT DD PRO today. After some extensive troubleshooting and research I am at a loss connecting my setup to my primary PC. I followed the instructions provided and some from the forums, but it seems like my issue is more specific. Below are my PC specs:

AMD Ryzen 7 5800x

ASUS PRIME X570 Pro (latest BIOS flash)

Windows 10 Pro 64 bit

I can confirm the equipment received is for sure functional as I am able to connect to my laptop, update drivers/firmware, and calibrate all 4 of my Fanatec connected devices (Shifter, Handbrake, and V3 Pedals). This steered me towards this being a PC error on my primary, so I went digging deeper into my PC that would be causing issues. 

I downgraded my system from Windows 11 to Windows 10 to match my laptop (No Luck)

I upgraded the BIOS to latest version (No Luck)

I verified the proper USB drivers are running and functioning. Below are some errors I was having:

When plugging in wheelbase to PC, I periodically get "Unknown USB Device (Device Descriptor Request Failed)". Also when running the firmware version 439, it will install properly, but will keep my PC in a restart state (over an hour so I hard shut the PC down and restarted). I replicated this issue with installing the firmware on both Windows 11 and Windows 10 after a fresh install. When going to repair the firmware, it will get stuck 3/4 way through repairing (same thing happens when uninstalling). It has been putting my PC into an unresponsive state when restarting and I need to hard shut down the PC twice to get it to boot. 

At this point I am looking for any clarification aside from all the usual information that can be found browsing the forum posts. I have not seen another individual with this specific issue, so it's a bit hard to troubleshoot at this point. 

I have also yet seen the wheelbase populate under the "Game Controllers" menu. It will show at times under "Devices and Printers", but it's a 50/50 if it connects for communication.

I have had it at the firmware screen plenty of times for the wheelbase firmware flash. it shows that it connects, but when running the flash, the bar doesn't progress at all. When I ran this on my laptop it was well and done within 10 seconds.

This is obviously a specific Windows issue I am having with the firmware tool working with Windows, I would appreciate any clarification. I can provide more information as needed! Thanks all!


  • Hi, I don't know for sure if this will help, but maybe worth a try. Below is post from "nin chan". I used this method to update my V3 pedal FW which I could not do without installing Visual Studio x86 version.

    Firmware update ClubSport Pedals V3 inverted

    Hi guys,

    I got the same problem here, the pedal stucks in v1.30 and unable to update, but finally got it fixed.

    When trying to launch "fwpedalupdater.exe" in the folder fanatec/fw/ manually, it said missing vcruntime140.dll and msvcp140.dll. These two are Visual C++ files.

    Then I installed back Visual C++ Redistributables. https://docs.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist

    Not sure which versions are a must since I had tried to install all x64 with no luck. Then i got the updater successfully ran after installing 2015-2022 x86. So, i guess probably "Visual Studio 2015, 2017, 2019, 2022" x86 version, maybe x64 necessary as well.

    If the updater successfully run, then just close it and update the firmware as usual with Fanatec Control Panel.

    Good luck mate. Hope it helps.

  • The issue winded up being the USB-C cable sent with the wheelbase. I winded up swapping the cable after a few days to test it out and it winded up connecting with no issues after the fact. Seems like the cable did not want to get a clean connection with my PC consistently. The USB-A end would need to be unplugged into different ports back and forth until a clean connection was made. Bizarre, but at least I found the root of the issue.

    TLDR; if you are having issues with Windows not recognizing the device when connecting try swapping cables a little sooner then myself!

Sign In or Register to comment.