Clubsport V3 Inverted Brake Pedal not working only

Hi everyone, I recently bought the Fanatec's GT DD pro wheel base, McLaren wheel, and Clubsport V3 inverted pedals. Everything is plugged in and set up correctly, drivers were a breeze too. The only issue is when I press down on my brake pedal nothing happens. I checked the usb controller (windows) and Fanatec Control Panel, Fanlab and its the same, it reads the Gas and Clutch pedal just not the brake. The brake vibration test also works.

I am at a loss, I have reached out to Tech support but I have yet to hear back from them.

Anyone run into the same issue? I have tried reinstalling drivers complete, checking cable connections and making sure they are secure.

Connections: McLaren Wheel on GT DD Pro wheelbase - only cables here are the usb-c to usb (PC) and the 4 pin power cable. CS V3 pedals are plugged into via usb to pc. I have also tried connecting the RJ12 into the wheelbase and not use the usb cable but I have the same issue happening.


PC Driver 439

Wheel Base

Wheel Base motor

Steering Wheel 44

Wireless QR

Pedals 1.32


  • Vel,

    Did you have the problem resolved?

    I currently have CSL pedals + LC pedals and the pedals are not working after 9 months.

    I am thinking of getting the V3 inverted but afaird they will do the same.

Sign In or Register to comment.