Fanatec CSL Elite brake pedal port broken?

Hi all

I have the Fanatec CSL Elite F1 set.. Last year shortly after buying it the brake pedal stopped registrering input.. Accelerator worked fine. I did some troubleshooting myself before contacting support and found out that if i plugged the accelerator into the brake port in the small electronic black box and the brake into the gas port the brake was working while the accelerator was not.. (accelerator becomes brake and brake becomes accelerator).. Got a new box from fanatec and send them the old one but they could not see any problems with it while testing.

After replacing the black electronics box it have been working fine until now.. Tried replacing the cable from the pedals to the wheelbase to see if it was damaged but nothing changed. Have anyone else experienced the same?


  • Randy AllenRandy Allen Member
    edited June 2020

    Hi Marcus, I JUST started having the same exact problem tonight with my CSL Elite F1 set. I haven't trouble shot as far as you did. (Swapping the throttle and brake ports on the box.) but Throttle, along with everything else (all other buttons on wheel) work. When I go into the settings in F1 2019 game, and check the calibration, throttle works, steering wheel, but NO brakes. I'm thinking its the cable that goes from the pedals to the wheel. Is that just a regular RJ12 that I could get a staples, or do I HAVE to use the one from Fanatec? ( I did try to update the firmware, but even in the Fanatec software on my laptop, still doesn't read the brake pedal. Everything else registers.)

  • Hi again Marcus, Well I just figured out what my dumb butt did. I had moved my break pedal over a space or two. When I did, I wasn't paying attention and pinched the rj11 cable almost in half. The little cable that goes from the break potentiometer, and plugs into the brake plug in the box. So it looks like I will be splicing wires together tomorrow.

Sign In or Register to comment.