Fanatec DD1 base won't detect new Club Sport podium wheel

I recently purchased a F1 podium wheel and base, which came assembled. I also purchased pedals and a Club Sport podium wheel (that I had to assemble).

When I first tried out the assembled F1 wheel, everything was fine. I assembled the Club Sport wheel and attached it to the base. The base powered on, but the wheel didn’t. So I put on the original F1 wheel (that had previously worked fine) and it again worked fine.

Is there something that I need to do to get the Club Sport podium wheel (which I assembled) to power up (or be “detected” by the base)? I know that with the F1 podium wheel that came with the base it calibrated or did something to the wheel when I updated the firmware. And it asked if I wanted to do another wheel. Because I hadn’t assembled the Club Sport yet, I said no. Could that be the problem?

The pins in the Club Sport are fine. The wire behind the wheel is plugged in. I’m sure I’m attaching the wheel properly because the F1 wheel attaches fine.

Any ideas on why the DD1 base won’t detect the Club Sport wheel but will detect the F1 wheel?


  • I'm having a very similar issue. New dd1 F1 bundle. Got the wrc, McLaren gt3, and Porsche clubsport wheels.

    Every wheel works perfectly except for the Porsche wheel. I can hot swap wrc, McLaren, and f1 wheels on PS5 and pc, I can hot swap McLaren and wrc wheels on Xbox. Every component, base / shifter / handbrake / wheels / endurance module are updated to latest firmware.

    The clubsport hub is a bastard. It randomly decides whether or not it wants to work, on any system. I've managed to update the hub and endurance button module to latest fw, but regardless of which system I'm using, and whether or not I have the endurance module plugged into the usb port on the bottom of the clubsport hub, more than half the time it wont work.

    When I turn on the base with the clubsport hub engaged, either the screen on the hub / endurance module will stay blank while the torque warning is on the base screen, or the base won't turn on properly with the screen staying blank. Buttons don't work on hub or endurance module.

    When I hot plug the clubsport hub while the base is on, it either fails to notice that the hub is plugged in, or the screen on the base goes dark. Behaviour persists whether the endurance module is connected or not, and regardless of if the clubsport hub is the first thing I plug in after the base is on, or if I had something else plugged in first.

    On very rare occasions, the Porsche clubsport wheel bundle works. I have no idea why, or how to make it happen again. I'm hoping it's just an issue with the clubsport hub, and gonna try to rma it on monday

  • I have the same problem, the base never detects the Porsche steering wheel with podium hub. I sent a request to fanatec after-sales service

  • Ook ik heb hetzelfde probleem.

    Vervelend dat het in mijn geval slechts 1 keer heeft gewerkt en daarna nooit meer.

    De storing is dus willekeurig en niet permanent.

    Al een reactie van Fanatec ontvangen?

  • Me the same. Upgraded from CSW Base V2.5 to the Podium racing wheel F1 (DD1). Updated all drivers and firmware were needed. The ClubSport Steering Wheel F1® PS4 work perfectly fine. Also the ClubSport Steering Wheel Formula V2 and CSL Elite Steering Wheel WRC which I already owned works as they should. When I tried my ClubSport Steering Wheel Universal Hub for XBOX ONE the screen from the wheelbase went black. I tried several time on and off but no response at all from the hub. Then I tried it again on my CSW Base V2.5 and guess what, on that one as before perfect. So after reading the other complaints about this issue we may conclude that the working between DD wheel bases and the universal hubs is rubbish and has not been properly tested by Fanatec.

    So Fanatec, what are you going to do to solve this problem for your well paying customers?

  • edited November 2022

    Got my podium today and experencing the exact same behaviour.... Did you sort out?

    I'll call support tomorrow :-(

  • Hi

    i have the same issue with my new Podium Wheel F1 and the Universal hub V2.

    sometimes is work and sometimes Not.

    havé Young resolve the issue ? Or had we call the support ?

  • Oh really? Also with the universal hub V2? That is disturbing. I thought it was only with the V1 and I was considering buying the V2 but now I am not so sure…

  • edited November 2022

    I have to send Podium and universal hub back in Fanatec.... 😥

  • If you want to speed it up the process i'll suggest to call the guys. The want you to do some test / check and you gain days compare to wait for email.

  • Did you get your wheelbase back yet? Did they actually fix the issue?

  • My problem is solved!! I created a support ticket and the day after I already got the first response. I was asked to try some things but this didn’t work. Every time I send an e-mail, the support team responded very quick. Never longer then a day and they were very constructive. I just kept a positive and friendly tone because I believe you get back what you give.

    I got the request to send back my Podium Steeringwheel F1 and the Universal hub V2 for Xbox. After I delivered my stuff at my local postal office, it was repaired and returned to me within 10 days. I mean, this is a very good effort. Only thing that could be better is to inform me what has been done. What I can see is a firmware update on the wheel base. Don’t know if there was a modification hardware wise.

    I read so many negatives on the forum and socials that I want to share my positive experience. I hope this help you if you experience the same kind of trouble😉

Sign In or Register to comment.