Clubsport Porsche GT3 for Xbox not connecting to DD2.

Just set up my Fanatec stuff on Thursday, from the beginning my wheel wasn't being recognized. I was somehow able to get it to work Thursday evening with the recovery tool in the firmware manager. After turning it off for the night and coming back the next day same thing happened. I tried reinstalling the driver and all firmware, but I messed this up and had to spend most of Friday try to get my base and motor to start communicating after reinstalling the firmware in the wrong order. Now that I've got that sorted I'm back to my original problem and can't really find online that's helped me solve it. If anyone's had a similar experience and got it sorted, please let me know how. Started a ticked, but if it can be solved with advice on here I'd much rather that then go through the headache of dealing with support. I'm quite disappointed and unhappy this has been my experience right out of the box with Fanatec and the lack of support.


  • Something else that may be important is that I can only attempt to perform the firmware update recovery on the wheel. It just shows the regular firmware update button for the PBME, but its grey and can't be clicked on. As for trying the update recover one the wheel, it never works. Unfortunately, I don't remember what I did differently the one time I got it to work. Seeing as it stoped working after I turned it off and back on again, I'm not sure whatever I did was right anyway.

Sign In or Register to comment.