CSL DD not powering on, but sometimes does?

Hey guys,

I was lucky to get my hands on the CSL DD wheelbase when it first released and I’ve had a great experience thus far. Earlier this year a problem with my wheelbase occurred. The wheelbase wouldn’t turn on when pressing the power button. The strange thing is that after a while I would randomly press the button again in hope of it turning on and it would actually turn on in some cases and I could play again.

I thought it was a hardware problem, maybe with the power connector on the back of the DD so I contacted Fanatec support and they told me to send the wheelbase in for an inspection. Then I receive an email that the wheelbase is on its way to my house and that the problem should be resolved. They did some testing and found a minor fault in the power supply and exchanged it. I was happy to know what was wrong but when I tried it again the same problem occurred. It really seems like it didn’t help at all. That was a few months ago and since then I haven’t used it that much because it won’t turn on regularly. Now I’m finally getting into sim racing again so I tried it again today and it didn’t work. While writing this I pressed the button randomly and it turned on and I updated the hardware and drivers. Then I turned it off to “restart” it and it won’t turn on again.

It is also noteworthy that I have tried everything possible to look after a fault on my end. I plugged the USB cable into different ports on my PC. I also tried a different power outlet and cleaned the connectors from dust with air compression.

I’m very frustrated with this situation and don’t know what to do anymore so now I would like to hear if any of you ran into similar problems or if there is a solution to this problem.

Thanks for your time and hopefully I can get this problem fixed with your help.

Best regards

Sign In or Register to comment.