DD1 not found in fanatec driver.

has been working fine but now its not being detected by fanatec drivers ive tried most of the drivers available. also not being detected by windows. it pops up and says "windows does not recognize usb device" whenever plugged in. the fans on the dd1 are operating at normal speeds. also when the dd1 is plugged in it shows on windows device manager. ive tried pretty much all i can do but i hope somebody can help.

also ive attached a pic of all the drivers i have attempted to use. all result in "no fanatec device found"


  • Try different USB ports on your Motherboard.

  • have tried all including usb 2.0 and 3.0 ports with no results unfortunately

  • I had some problems with the Fanatec drivers and the DD1 base not long ago, what worked was to install the v336 version. 

    So : 

    - Uninstall all Fanatec drivers 

    - Reinstall the 336 driver

    - Reboot your pc (the base must be off) 

    - Press 10 seconds on the power button of the base until it blinks, a Fanatec popup should open to flash the firmware

    - The firmware installation should start on your PC

    Once all firmwares are updated, you can reinstall the last driver, everything should be fine 

Sign In or Register to comment.