csl elite base and wheel ps4 licensed version. Never worked


Wheel never worked

Original Message

Hi guys I turned on my base and wheel for the first time yesterday. No lights came up on the wheel it’s self, just the base had the first 3 amber lights on and the red mode/power light was flashing. I downloaded the 64bit driver for the wheel base from your site, and followed the prompts but still no change. The fanatec controllers page/connected devices viewer program does not show the base or wheel. So I held the power button while base was powered off, activated bootstrapper mode and downloaded the most recent firmware and reset the pc as requested and still nothing in the device viewer and no change to the base lights and flashing red light. Still never seen any lights ever come on in the wheel itself, I read the forum for fixes, I changed from 3.0usb port to 2.0 and still no go. I uninstalled everything and tried with the forums latest Drivers and firmware while Having firewall and antivirus turned off. Still nothing. I blew some air from an into the First hole under the lights to try and maybe clean the wheel sensor and sill nothing. Can you help me please


CSL Elite Racing Wheel - officially licensed for PS4™


PC - Windows 10 - 64 bit

Sign In or Register to comment.