Podium F1 Firmware Versions in PC Comp mode

Hi everyone,

I tried to google but didn‘t find an answer to the situation.

I have a Podium F1 DD1 wheelbase and the latest driver 447 installed. While being in PC mode through the driver I successfukky updated to the latest wheel base firmware ( and the latest wheel base motor firmware ( Afterwards closed the driver - so good so far.

Meanwhile I played Project Cars 2, where it is recommended to put the wheel base in „PC comp mode“ and left the wheel base in this mode.

Recently I got a new steering wheel and wanted to see if there is a new firmware for it available as well and after starting the Fanatec Control Panel it prompted that indeed there is a new firmware available and it put me right to the firmware updater.

All that I was still in „PC comp mode“ and the firmware updater didn’t just show a new version for the steering wheel but also for a „Clubsport Wheel Base V2.5 Motor Firmware“ (installed version 3 and available firmware V22) and also a „Clubsport Wheel Base V2.5 Firmware“ (installed version 3 and available V691).

I switched back to PC mode and did only update the steering wheel firmware at the moment.


Is it save to install the new firmware versions of the shown Clubsport Wheelbase V2.5 while being in „PC comp mode“ on a Podium F1 DD1?


  • NO!

    Do NOT update to this mysterious ClubSport Firmwares, high risk to brick your base by doing so.

    This should not happen, in both PC and PC COMP modes the exact same Firmware of the Podium DD should be shown.

    Can you reproduce this behaviour by switching to PC COMP mode again?

    I just tried and I cant reproduce this, its showing the correct Podium DD Firmware also in PC COMP mdoe for me, seems something strange is happening for you...

  • edited December 2022

    Hi Maurice,

    ok, then I´m glad I switched back to PC mode to only update the steering wheel.

    But yeah, definitely reproducable in PC Comp Mode. I cycled through the modes and switched off and on the wheel base as well. In PC comp mode in the "normal" menu of the control panel the firmwares show correctly, but in the firmware updater/manager the CSW2.5 firmwares come up (see attachments).

Sign In or Register to comment.