Universal Hub V2 for Xbox not Recognized by DD2

So, my first problem is that the hub doesn’t seem to be getting power. So, I then looked at the points and they all look straight none seem broken. Then I started firmware updates through there FAnatec Control Panel. All that it recognizes is the pedals. And every time I would try and restart the wheelbase I was met by

FAnatec Firmware Updater

UPDATE MODE: CSL Elite Steering Wheel McLaren GT3 (V2.0)    (BTW that isn’t the type of wheel I have)

Flash Firmware

Firmware File: …\default.hex

Message Logs McLaren GT3 (V2) Steering Wheel Update Mode

Connected to device successfully!

Connected device information……

Deceive information is updated!

So, then I would press Flash Firmware and it would seem to be updating the fan on my wheelbase would slow down and for a hot second it would recognize it through the control panel. Then immediately it would go back to not recognizing it and the same message from Fanatec Firmware Updater would pop up. Now when I remove the wheel from the base and restart the base without a wheel or hub it recognizes the wheelbase but as soon as I put the wheel/hub back on it brings me the firmware updater message again. I’ve tried unplugging and plugging it back in, I’ve tried rebooting, and it says all my firmware is up to date.

I’m new to Fanatec gear so I might just be missing something that’s in my face, but some help would be greatly appreciated. 


  • Never mind I took apart the wheel and put it back together and for some reason that worked. I wont question it.

Sign In or Register to comment.